NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

SQL Injection in sequelizeGHSA-2598-2f59-rmhq

CRITICALFix: sequelize/sequelize@ee40173

GHSA-2598-2f59-rmhq is a critical-severity (CVSS 9.8) SQL Injection vulnerability in sequelize. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for sequelize — see the affected versions and patch details below.

Also known asCVE-2019-10749SNYK-JS-SEQUELIZE-450222
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs69th percentile — riskier than 69% of all scored CVEsHighest risk
0.00%0.58%1.15%1.73%0.4%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

7Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
sequelizenpm
4.1Mdownloads / week

Description

Versions of sequelize prior to 3.35.1 are vulnerable to SQL Injection. The package fails to sanitize JSON path keys in the Postgres dialect, which may allow attackers to inject SQL statements and execute arbitrary SQL queries.

Recommendation

Upgrade to version 3.35.1 or later.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmsequelizeall versions3.35.1npm install sequelize@3.35.1

Affected Products

1 product · 1 configurations
Application
sequelizesequelizejs
< 3.35.1
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for sequelize, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update sequelize to 3.35.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-2598-2f59-rmhq is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

Versions of `sequelize` prior to 3.35.1 are vulnerable to SQL Injection. The package fails to sanitize JSON path keys in the Postgres dialect, which may allow attackers to inject SQL statements and execute arbitrary SQL queries. ## Recommendation Upgrade to version 3.35.1 or later.
O3 Security · Impact-Aware SCA

Is GHSA-2598-2f59-rmhq in your dependencies?

Find it across npm, including transitive dependencies.

SQL Injection in sequelize (Critical 9.8)