CVE-2016-1000225 is a critical-severity (CVSS 9.8) vulnerability in sequelize. A fix is available for sequelize — see the affected versions and patch details below.
SQL Injection via GeoJSON in sequelize
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
sequelizenpmDescription
Affected versions of sequelize are vulnerable to SQL Injection in Models that have fields with the GEOMETRY DataType. This vulnerability occurs because single quotes in document values are not escaped for GeoJSON documents using ST_GeomFromGeoJSON, and MySQL GeoJSON documents using GeomFromText.
Recommendation
Update to version 3.23.6 or later.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | sequelize | ≥ 3.4.0&&< 3.23.6 | 3.23.6npm install sequelize@3.23.6 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for sequelize, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update sequelize to 3.23.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-1000225 is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Frequently Asked Questions
Is CVE-2016-1000225 in your dependencies?
Find it across npm, including transitive dependencies.