Specific Cilium configurations vulnerable to DoS via Kubernetes annotationsGHSA-24m5-r6hv-ccgp
LOWFix: cilium/cilium#27597GHSA-24m5-r6hv-ccgp is a low-severity (CVSS 3.5) CWE-755 vulnerability in github.com/cilium/cilium. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for github.com/cilium/cilium — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-24m5-r6hv-ccgp.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/cilium/cilium🐹github.com/cilium/cilium🐹github.com/cilium/ciliumReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
In Cilium clusters where Cilium's Layer 7 proxy has been disabled, creating workloads with
policy.cilium.io/proxy-visibilityannotations (in Cilium >= v1.13)io.cilium.proxy-visibilityannotations (in Cilium <= v1.12)
causes the Cilium agent to segfault on the node to which the workload is assigned.
Existing traffic on the affected node will continue to flow, but the Cilium agent on the node will not able to process changes to workloads running on the node. This will also prevent workloads from being able to start on the affected node. The denial of service will be limited to the node on which the workload is scheduled, however an attacker may be able to schedule workloads on the node of their choosing, which could lead to targeted attacks.
Patches
This issue affects:
Cilium <= v1.14.1 Cilium <= v1.13.6 Cilium <= v1.12.13
This issue has been resolved in:
Cilium v1.14.2 Cilium v1.13.7 Cilium v1.12.14
Workarounds
Users can avoid this denial of service attack by enabling the Layer 7 proxy.
For more information
If you have any questions or comments about this advisory, please reach out on Slack.
As usual, if you think you found a related vulnerability, we strongly encourage you to report security vulnerabilities to our private security mailing list: [email protected] - first, before disclosing them in any public forums. This is a private mailing list where only members of the Cilium internal security team are subscribed to, and is treated as top priority.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/cilium/cilium | ≥ 1.14.0&&< 1.14.2 | 1.14.2go get github.com/cilium/cilium@v1.14.2 |
| 🐹Go | github.com/cilium/cilium | all versions | 1.12.14go get github.com/cilium/cilium@v1.12.14 |
| 🐹Go | github.com/cilium/cilium | ≥ 1.13.0&&< 1.13.7 | 1.13.7go get github.com/cilium/cilium@v1.13.7 |
Affected Products
ciliumciliumResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/cilium/cilium, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/cilium/cilium to 1.14.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-24m5-r6hv-ccgp is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is GHSA-24m5-r6hv-ccgp in your dependencies?
Find it across Go, including transitive dependencies.