Exposure of class information in RESTEasyGHSA-244r-fcj3-ghjq
MEDIUMGHSA-244r-fcj3-ghjq is a medium-severity (CVSS 5.3) CWE-209 vulnerability in org.jboss.resteasy:resteasy-core. A fix is available for org.jboss.resteasy:resteasy-core — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.jboss.resteasy:resteasy-core☕org.jboss.resteasy:resteasy-core☕org.jboss.resteasy:resteasy-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
A flaw was found in RESTEasy in all current versions of RESTEasy up to 4.6.0.Final. The endpoint class and method names are returned as part of the exception response when RESTEasy cannot convert one of the request URI path or query values to the matching JAX-RS resource method's parameter value. The highest threat from this vulnerability is to data confidentiality.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.jboss.resteasy:resteasy-core | ≥ 4.6.0&&< 4.6.1 | 4.6.1org.jboss.resteasy:resteasy-core:4.6.1 |
| ☕Maven | org.jboss.resteasy:resteasy-core | ≥ 4.0.0&&< 4.5.10 | 4.5.10org.jboss.resteasy:resteasy-core:4.5.10 |
| ☕Maven | org.jboss.resteasy:resteasy-core | ≥ 3.0.0&&< 3.16.0 | 3.16.0org.jboss.resteasy:resteasy-core:3.16.0 |
Affected Products
oncommand insightnetappcommunications cloud native core consoleoraclequarkusquarkusresteasyredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jboss.resteasy:resteasy-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.jboss.resteasy:resteasy-core to 4.6.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-244r-fcj3-ghjq is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| EAP 7.3.10 GA | resteasy-jaxrs | RHSA-2021:5154 |
| Red Hat AMQ 7.9.0 | resteasy-jaxrs | RHSA-2021:3700 |
| Red Hat build of Quarkus 2.2.3 | resteasy-core | RHSA-2021:3880 |
| Red Hat EAP-XP 2 via EAP 7.3.x base | resteasy-jaxrs | RHSA-2022:0146 |
| Red Hat Integration Camel Quarkus 2 | see advisory | RHSA-2021:4767 |
| Red Hat JBoss Enterprise Application Platform | org.jboss.resteasy/resteasy-jaxrs:3.15.2.Final-redhat-00001 | RHSA-2021:4679 |
| Red Hat JBoss Enterprise Application Platform 7.3 for RHEL 6 | eap7-apache-cxf-0:3.3.12-1.redhat_00001.1.el6eap | RHSA-2021:5149 |
| Red Hat JBoss Enterprise Application Platform 7.3 for RHEL 7 | eap7-apache-cxf-0:3.3.12-1.redhat_00001.1.el7eap | RHSA-2021:5150 |
Frequently Asked Questions
Is GHSA-244r-fcj3-ghjq in your dependencies?
Find it across Maven, including transitive dependencies.