CVE-2020-10688 — resteasy-bom
MEDIUMCVE-2020-10688 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.jboss.resteasy:resteasy-bom. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.jboss.resteasy:resteasy-bom — see the affected versions and patch details below.
Cross-site scripting in RESTEasy
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.jboss.resteasy:resteasy-bom☕org.jboss.resteasy:resteasy-bom☕org.jboss.resteasy:resteasy-core☕org.jboss.resteasy:resteasy-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
A cross-site scripting (XSS) flaw was found in RESTEasy in versions before 3.11.1.Final and before 4.5.3.Final, where it did not properly handle URL encoding when the RESTEASY003870 exception occurs. An attacker could use this flaw to launch a reflected XSS attack.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.jboss.resteasy:resteasy-bom | all versions | 3.11.1.Finalorg.jboss.resteasy:resteasy-bom:3.11.1.Final |
| ☕Maven | org.jboss.resteasy:resteasy-bom | ≥ 4.0.0&&< 4.5.3.Final | 4.5.3.Finalorg.jboss.resteasy:resteasy-bom:4.5.3.Final |
| ☕Maven | org.jboss.resteasy:resteasy-core | all versions | 3.11.1.Finalorg.jboss.resteasy:resteasy-core:3.11.1.Final |
| ☕Maven | org.jboss.resteasy:resteasy-core | ≥ 4.0.0&&< 4.5.3.Final | 4.5.3.Finalorg.jboss.resteasy:resteasy-core:4.5.3.Final |
Affected Products
fuseredhatjboss enterprise application platformredhatopenshift application runtimesredhatresteasyredhatResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jboss.resteasy:resteasy-bom, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.jboss.resteasy:resteasy-bom to 3.11.1.Final or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-10688 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| EAP-CD 19 Tech Preview | resteasy | RHSA-2020:2333 |
| Red Hat Fuse 7.9 | resteasy | RHSA-2021:3140 |
| Red Hat JBoss EAP 7 | resteasy | RHSA-2020:2515 |
| Red Hat JBoss Enterprise Application Platform 7.3 for RHEL 6 | eap7-activemq-artemis-0:2.9.0-4.redhat_00010.1.el6eap | RHSA-2020:2511 |
| Red Hat JBoss Enterprise Application Platform 7.3 for RHEL 7 | eap7-activemq-artemis-0:2.9.0-4.redhat_00010.1.el7eap | RHSA-2020:2512 |
| Red Hat JBoss Enterprise Application Platform 7.3 for RHEL 8 | eap7-activemq-artemis-0:2.9.0-4.redhat_00010.1.el8eap | RHSA-2020:2513 |
| Red Hat Runtimes Spring Boot 2.2.6 | resteasy | RHSA-2020:3806 |
| Text-Only RHOAR | see advisory | RHSA-2020:2905 |
Frequently Asked Questions
Is CVE-2020-10688 in your dependencies?
Find it across Maven, including transitive dependencies.