NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2016-9606 — resteasy-bom

HIGH

CVE-2016-9606 is a high-severity (CVSS 8.1) Improper Input Validation vulnerability in org.jboss.resteasy:resteasy-bom. A fix is available for org.jboss.resteasy:resteasy-bom — see the affected versions and patch details below.

JBoss RESTEasy vulnerable to Improper Input Validation

Also known asGHSA-hgjr-xwj3-jfvw
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
6.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs93th percentile — riskier than 93% of all scored CVEsHighest risk
1.09%3.18%5.27%7.35%2.3%6.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jboss.resteasy:resteasy-bom

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

JBoss RESTEasy before version 3.1.2 could be forced into parsing a request with YamlProvider, resulting in unmarshalling of potentially untrusted data which could allow an attacker to execute arbitrary code with RESTEasy application permissions.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jboss.resteasy:resteasy-bomall versions3.1.2.Finalorg.jboss.resteasy:resteasy-bom:3.1.2.Final

Affected Products

1 product · 1 configurations
Application
resteasyredhat
≤ 3.1.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jboss.resteasy:resteasy-bom, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jboss.resteasy:resteasy-bom to 3.1.2.Final or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-9606 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

YamlProvider was removed the default list of providers to prevent a malicous user from requesting a payload be marshalled with Yaml. If marshalling of Yaml content is desired, add, or append a file with the name 'META-INF/services/javax.ws.rs.ext.Providers' to your WAR, or JAR with the contents…

Workaround published by Red Hat
Add authentication and authorization to any Resteasy endpoint which doesn't define a mime type, or defines a multipart mime type.
Source: Red Hat security advisory for CVE-2016-9606 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat JBoss BPMS 6.4see advisoryRHSA-2017:1675
Red Hat JBoss BPMS 7.1see advisoryRHSA-2018:2909
Red Hat JBoss BRMS 6.4see advisoryRHSA-2017:1676
Red Hat JBoss BRMS 7.1see advisoryRHSA-2018:2913
Red Hat JBoss EAP 7.0see advisoryRHSA-2017:1409
Red Hat JBoss Enterprise Application Platform 6.4see advisoryRHSA-2017:1255
Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 5hibernate4-eap6-0:4.2.26-1.Final_redhat_1.1.ep6.el5RHSA-2017:1256
Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 6hibernate4-eap6-0:4.2.26-1.Final_redhat_1.1.ep6.el6RHSA-2017:1254

Frequently Asked Questions

JBoss RESTEasy before version 3.1.2 could be forced into parsing a request with YamlProvider, resulting in unmarshalling of potentially untrusted data which could allow an attacker to execute arbitrary code with RESTEasy application permissions.
O3 Security · Impact-Aware SCA

Is CVE-2016-9606 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2016-9606: resteasy-bom RCE — Fixed in 3.1.2.Final