CVE-2026-82410 — pocketbase
Fix: pocketbase/pocketbase@30b4184CVE-2026-82410 is a CWE-248 vulnerability in github.com/pocketbase/pocketbase. A fix is available for github.com/pocketbase/pocketbase — see the affected versions and patch details below.
Pocketbase: Unhandled panic in worker goroutines
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-82410.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
github.com/pocketbase/pocketbase🐹github.com/pocketbase/pocketbaseReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
PocketBase already has builtin panic-recover middleware for the regular requests handling but it doesn't cover panics in internal child/worker goroutines which in some situations could cause termination of the server process.
To prevent this from hapenning all existing internal worker functions were wrapped with the new helper routine.SafeWrap(f) (auto recovers and returns any eventual panic as regular error).
The vulnerability was reported by @gigioneggiando and it is strongly recommended to upgrade to PocketBase v0.39.7 (the fix was also backported in v0.22.48 in case you are using older PocketBase < v0.23.0).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/pocketbase/pocketbase | all versions | 0.22.48go get github.com/pocketbase/pocketbase@v0.22.48 |
| 🐹Go | github.com/pocketbase/pocketbase | ≥ 0.23.0&&< 0.39.7 | 0.39.7go get github.com/pocketbase/pocketbase@v0.39.7 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/pocketbase/pocketbase, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/pocketbase/pocketbase to 0.22.48 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-82410 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2026-82410 in your dependencies?
Find it across Go, including transitive dependencies.