CVE-2026-69149 — @angular/platform-server
Fix: angular/angular#69675CVE-2026-69149 is a Cross-site Scripting (XSS) vulnerability in @angular/platform-server. A fix is available for @angular/platform-server — see the affected versions and patch details below.
Angular SSR: Missing Fallback Raw-Content Serialization Escaping leads to Cross-Site Scripting (XSS)
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-69149.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@angular/platform-servernpmDescription
A Cross-Site Scripting (XSS) vulnerability exists in @angular/platform-server's DOM emulation dependency (domino) when serializing the content of fallback raw-content elements (<iframe>, <noembed>, <noframes>, and <noscript>).
When rendering dynamic text content inside fallback raw-content elements via template bindings, the template engine expects the browser to render the content safely. Under Server-Side Rendering (SSR), domino is configured with scripting enabled, meaning these elements are treated as raw-text elements.
However, domino's serializer previously did not escape text nodes within fallback raw-content elements (<iframe>, <noembed>, <noframes>, <noscript>) during DOM serialization. As a result, any occurrence of closing tags in the bound dynamic text was not escaped.
The unescaped closing tag could be serialized directly into the output HTML. When parsed by a browser or re-parsed during SSR post-processing without preserving raw-content parser state, an injected closing tag closes the element early, allowing an injected script block to execute in the user's browser context, causing same-origin Cross-Site Scripting (XSS).
Impact
This vulnerability allows an attacker to perform same-origin Cross-Site Scripting (XSS) attacks against any user visiting an SSR-rendered page that binds user-controlled data inside fallback raw-content elements (<iframe>, <noembed>, <noframes>, <noscript>). This can lead to session hijacking, credentials theft, unauthorized actions on behalf of users, and defacement.
Patched Versions
- 22.0.7
- 21.2.19
- 20.3.27
Workarounds
If you cannot immediately update your dependencies, you can mitigate this issue using any of the following approaches:
- Disable critical CSS inlining: Critical CSS inlining in Angular SSR post-processes the rendered HTML using
domino. Disabling this step preventsdominofrom re-parsing and re-serializing the HTML during server-side rendering.- In
angular.json, setinlineCriticaltofalseunder style optimization options:{ "projects": { "my-app": { "architect": { "build": { "builder": "@angular/build:application", "options": { "optimization": { "styles": { "inlineCritical": false } } } } } } } } - When rendering programmatically with
CommonEngine, setinlineCriticalCss: falsein your render options.
- In
- Avoid binding user-controlled values inside fallback raw-content elements (
<iframe>,<noembed>,<noframes>,<noscript>). - Sanitize user input placed inside these elements to explicitly strip or escape closing tags before passing it to the template.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @angular/platform-server | ≥ 22.0.0-next.0&&< 22.0.7 | 22.0.7npm install @angular/platform-server@22.0.7 |
| 📦npm | @angular/platform-server | ≥ 21.0.0-next.0&&< 21.2.19 | 21.2.19npm install @angular/platform-server@21.2.19 |
| 📦npm | @angular/platform-server | ≥ 20.0.0-next.0&&< 20.3.27 | 20.3.27npm install @angular/platform-server@20.3.27 |
| 📦npm | @angular/platform-server | all versions | No fix |
Affected Products
angularangularDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @angular/platform-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @angular/platform-server to 22.0.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-69149 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2026-69149 in your dependencies?
Find it across npm, including transitive dependencies.