NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
.NET NuGet
Not in CISA KEV

CVE-2026-56379 — Magick.NET-Q16-AnyCPU

Fix: ImageMagick/ImageMagick@9db9636

CVE-2026-56379 is a CWE-116 vulnerability in Magick.NET-Q16-AnyCPU. A fix is available for Magick.NET-Q16-AnyCPU — see the affected versions and patch details below.

ImageMagick - Command Injection via SVG Decoder

Also known asGHSA-xpg8-7m6m-jf56
Published
Updated
Affected
19 pkgs
Patched
19 / 19
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-56379.

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs77th percentile — riskier than 77% of all scored CVEsHighest risk
0.38%0.97%1.56%2.14%1.2%1.6%Jul 26Oct 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

19 pkgs affected
.NETMagick.NET-Q16-AnyCPU.NETMagick.NET-Q16-HDRI-AnyCPU.NETMagick.NET-Q16-HDRI-OpenMP-arm64.NETMagick.NET-Q16-HDRI-OpenMP-x64.NETMagick.NET-Q16-HDRI-arm64.NETMagick.NET-Q16-HDRI-x64.NETMagick.NET-Q16-HDRI-x86.NETMagick.NET-Q16-OpenMP-arm64+11 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.

Description

ImageMagick before 7.1.2-15 and 6.9.13-40 contains a command injection vulnerability in the SVG decoder that allows attackers to inject arbitrary MVG drawing commands. Attackers can craft malicious SVG files with injected Magick Vector Graphics commands that execute during rendering.

Affected Packages

19 total 19 fixed
EcosystemPackageVulnerable rangeFix
.NETNuGetMagick.NET-Q16-AnyCPUall versions14.10.3dotnet add package Magick.NET-Q16-AnyCPU --version 14.10.3
.NETNuGetMagick.NET-Q16-HDRI-AnyCPUall versions14.10.3dotnet add package Magick.NET-Q16-HDRI-AnyCPU --version 14.10.3
.NETNuGetMagick.NET-Q16-HDRI-OpenMP-arm64all versions14.10.3dotnet add package Magick.NET-Q16-HDRI-OpenMP-arm64 --version 14.10.3
.NETNuGetMagick.NET-Q16-HDRI-OpenMP-x64all versions14.10.3dotnet add package Magick.NET-Q16-HDRI-OpenMP-x64 --version 14.10.3
.NETNuGetMagick.NET-Q16-HDRI-arm64all versions14.10.3dotnet add package Magick.NET-Q16-HDRI-arm64 --version 14.10.3
.NETNuGetMagick.NET-Q16-HDRI-x64all versions14.10.3dotnet add package Magick.NET-Q16-HDRI-x64 --version 14.10.3

Affected Products

1 product · 2 configurations
Application
imagemagickimagemagick
≥ 7.1.0-0 && < 7.1.2-15
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Magick.NET-Q16-AnyCPU, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update Magick.NET-Q16-AnyCPU to 14.10.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-56379 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

An Important-rated vulnerability in the default configuration of Mojolicious::Plugin::Web::Auth::OAuth2 allows remote attackers to hijack user sessions. Because the plugin defaults to generating predictable security tokens, an attacker can bypass protections and launch Cross-Site Request Forgery (CSRF) attacks against…

Workaround published by Red Hat
Restrict ImageMagick processing capabilities via policy.xml, disabling the SVG coder and restricting delegates to prevent injection escalation to OS command execution. Enforce mandatory access control (SELinux/AppArmor) combined with seccomp syscall filtering to block execve. For systemd services, enable NoNewPrivileges, ProtectSystem=strict, ProtectHome=true, and PrivateDevices=true.
Source: Red Hat security advisory for CVE-2026-56379 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat Enterprise Linux 7 Extended Lifecycle SupportImageMagick-0:6.9.10.68-17.el7_9RHSA-2026:32961

Frequently Asked Questions

ImageMagick before 7.1.2-15 and 6.9.13-40 contains a command injection vulnerability in the SVG decoder that allows attackers to inject arbitrary MVG drawing commands. Attackers can craft malicious SVG files with injected Magick Vector Graphics commands that execute during rendering.
O3 Security · Impact-Aware SCA

Is CVE-2026-56379 in your dependencies?

Find it across NuGet, including transitive dependencies.

CVE-2026-56379: Magick.NET-Q16 — Fixed in 14.10.3