NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2026-49832 — dspace-api

HIGHFix: DSpace/DSpace#12548

CVE-2026-49832 is a high-severity (CVSS 8) Code Injection vulnerability in org.dspace:dspace-api. A fix is available for org.dspace:dspace-api — see the affected versions and patch details below.

DSpace: Remote Code Execution (RCE) possible in Velocity Templates used by LDN

Also known asGHSA-9x82-rm84-c6x7
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-49832.

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs59th percentile — riskier than 59% of all scored CVEsHighest risk
0.37%0.70%1.04%1.37%0.9%0.9%0.9%Oct 26Nov 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕org.dspace:dspace-api☕org.dspace:dspace-api☕org.dspace:dspace-api

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Overview

Remote Code Execution (RCE) is possible via Velocity Templates used by DSpace for COAR Notify/LDN messages. This vulnerability impacts DSpace versions 8.0 <= 8.3, 9.0 <= 9.2. The attacker MUST already have DSpace administrator credentials in order to perform the attack.

This attack is related to the path traversal attack identified in GHSA-9qm4-rh6w-pq5x as it was the impactful part of the "proof-of-concept" attack chain.

Impact

When chained with the LDN Path Traversal Attack identified in GHSA-9qm4-rh6w-pq5x, it may be possible to execute Java directly from Velocity templates using reflection. This is a very high impact vulnerability, but the attack can only be performed by a user that has DSpace Administrator privileges. Disabling LDN (see below) removes all known attack paths.

Velocity is also used for email templating, but there is no known attack path via emails templates. Nonetheless, the patches below also apply to email templates.

Patches

The fix is included in DSpace 8.4, 9.3 and 10.0. Please upgrade to one of these versions or disable LDN (see below)

If users cannot upgrade immediately, it is possible to manually patch their DSpace backend. (No changes are necessary to the frontend.) A pull request exists which can be used to patch systems running DSpace 8.x or 9.x.

Apply the patch to a DSpace instance

If at all possible, DSpace project maintainers recommend disabling LDN (see below) or upgrading a DSpace site based on the upgrade instructions. However, if users are unable to do so, they can manually apply the above patches to their Space backend as follows:

  1. Download the appropriate patch file to the machine where DSpace backend is running
  2. From the [dspace-src] folder, apply the patch, e.g. git apply [name-of-file].patch
  3. Now, update the application's DSpace site (based loosely on the Upgrade instructions). This generally involves three steps:
    1. Rebuild DSpace, e.g. mvn -U clean package (This will recompile all DSpace backend code)
    2. Redeploy DSpace, e.g. ant update (This will copy all newly built code to the application's installation directory). Depending on an application's setup users also may need to copy the updated "server" webapp over to their Tomcat webapps folder.
    3. Restart Tomcat (or runnable JAR)

Workarounds

  • In dspace.cfg or local.cfg, disable LDN (set ldn.enabled=false) if it is not crucial to the operation of the repository. (NOTE: LDN is disabled by default, so many DSpace sites may not use this feature)
  • Once users have patched theirr site or upgraded, they may safely enable LDN again.

Resources

This vulnerability is similar to vulnerabilities reported by Velocity itself:

Credits

Discovered & reported by Pablo Picurelli Ortiz (@superpegaso2703), cybersecurity student at Universidad Rey Juan Carlos. Reported as a possible attack combined with the LDN Path Traversal vulnerability. Code fix developed by Kim Shepherd (@kshepherd) of The Library Code

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.dspace:dspace-api≥ 8.0-rc1&&< 8.48.4org.dspace:dspace-api:8.4
☕Mavenorg.dspace:dspace-api≥ 9.0-rc1&&< 9.39.3org.dspace:dspace-api:9.3
☕Mavenorg.dspace:dspace-api≥ 10.0-rc1&&< 10.010.0org.dspace:dspace-api:10.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.dspace:dspace-api, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.dspace:dspace-api to 8.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-49832 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

## Overview Remote Code Execution (RCE) is possible via Velocity Templates used by DSpace for [COAR Notify/LDN messages](https://wiki.lyrasis.org/spaces/DSDOC9x/pages/379126679/COAR+Notify). _This vulnerability impacts DSpace versions 8.0 <= 8.3, 9.0 <= 9.2._ The attacker MUST already have DSpace administrator credentials in order to perform the attack. This attack is related to the path traversal attack identified in [GHSA-9qm4-rh6w-pq5x](https://github.com/DSpace/DSpace/security/advisories/GHSA-9qm4-rh6w-pq5x) as it was the impactful part of the "proof-of-concept" attack chain. ## Impact
O3 Security · Impact-Aware SCA

Is CVE-2026-49832 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2026-49832: dspace-api RCE — Fixed in 8.4