CVE-2026-49830 is a medium-severity (CVSS 4.4) Improper Input Validation vulnerability in org.dspace:dspace-api. A fix is available for org.dspace:dspace-api — see the affected versions and patch details below.
DSpace: ORE resource URI does not validate scheme for non-web resources
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-49830.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.dspace:dspace-api☕org.dspace:dspace-api☕org.dspace:dspace-api☕org.dspace:dspace-apiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Overview
When ingesting an aggregated ORE resource by URI (using the OAI-ORE Harvester), the ORE Ingestion Crosswalk does not validate the URI scheme. This may allow for local file inclusion via malicious paths like file:///etc/passwd. This vulnerability impacts DSpace versions <= 7.6.6, 8.0 <= 8.3, 9.0 <= 9.2. The attacker MUST already have DSpace collection administrator privileges in order to perform the attack.
Expected behaviour : Only external web resources should be ingested as ORE resources, preferably from the trusted endpoint.
Impact
A remote OAI endpoint configured as a harvest source for a DSpace collection can supply malicious ORE XML that results in a local file from the DSpace server being ingested as a bitstream.
Only Collection, Community and Site Administrators can configure a collection for OAI harvest, however an attacker may use stolen credentials to escalate into local file/data disclosure, or a compromised OAI endpoint could also supply malicious XML.
Patches
The fix is included in DSpace 7.6.7, 8.4, 9.3 and 10.0. Please upgrade to one of these versions or disable the ORE Crosswalk (see below).
If users cannot upgrade immediately, it is possible to manually patch their DSpace backend. (No changes are necessary to the frontend.) A pull request exists which can be used to patch systems running DSpace 7.6.x, 8.x or 9.x.
- Pull request for 9.x: https://github.com/DSpace/DSpace/pull/12541 (Downloadable patch file)
- Pull request for 8.x: https://github.com/DSpace/DSpace/pull/12543 (Downloadable patch file)
- Pull request for 7.x: https://github.com/DSpace/DSpace/pull/12542 (Downloadable patch file)
Apply the patch to a user's DSpace
If at all possible, we recommend disabling the ORE Crosswalk (see below) or upgrading a user's DSpace site based on the upgrade instructions. However, if they are unable to do so, they can manually apply the above patches to their DSpace backend as follows:
- Download the appropriate patch file to the machine where DSpace backend is running
- From the
[dspace-src]folder, apply the patch, e.g.git apply [name-of-file].patch - Now, update the DSpace site (based loosely on the Upgrade instructions). This generally involves three steps:
- Rebuild DSpace, e.g.
mvn -U clean package(This will recompile all DSpace backend code) - Redeploy DSpace, e.g.
ant update(This will copy all newly built code to their installation directory). Depending on their setup they also may need to copy the updated "server" webapp over to their Tomcat webapps folder. - Restart Tomcat (or runnable JAR)
- Rebuild DSpace, e.g.
Workarounds
- Disable the ORE ingestion crosswalk in
dspace.cfgby commenting out or removing it from the list ofplugin.named.org.dspace.content.crosswalk.IngestionCrosswalkplugins:
# Remove or comment out this line
org.dspace.content.crosswalk.OREIngestionCrosswalk = ore, \
- Once they have patched their site or upgraded, they may safely enable the OREIngestionCrosswalk again.
Credits
Discovered & reported by Pablo Picurelli Ortiz (@superpegaso2703), cybersecurity student at Universidad Rey Juan Carlos. Code fix developed by Kim Shepherd (@kshepherd) of The Library Code
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.dspace:dspace-api | all versions | 7.6.7org.dspace:dspace-api:7.6.7 |
| ☕Maven | org.dspace:dspace-api | ≥ 8.0-rc1&&< 8.4 | 8.4org.dspace:dspace-api:8.4 |
| ☕Maven | org.dspace:dspace-api | ≥ 9.0-rc1&&< 9.3 | 9.3org.dspace:dspace-api:9.3 |
| ☕Maven | org.dspace:dspace-api | ≥ 10-rc1&&< 10.0 | 10.0org.dspace:dspace-api:10.0 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.dspace:dspace-api, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.dspace:dspace-api to 7.6.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-49830 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2026-49830 in your dependencies?
Find it across Maven, including transitive dependencies.