NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2026-49255 — electerm

HIGHFix: electerm/electerm@aa77881

CVE-2026-49255 is a high-severity (CVSS 8.8) OS Command Injection vulnerability in electerm. A fix is available for electerm — see the affected versions and patch details below.

electerm: Command Injection in File System Operations (rmrf, mv, cp)

Also known asGHSA-v5ff-xmfp-p245
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-49255.

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs56th percentile — riskier than 56% of all scored CVEsHighest risk
0.03%0.45%0.87%1.29%0.5%0.8%0.8%0.8%Sep 26Nov 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

0other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
electermnpm
2Kdownloads / week

Description

Impact

A command injection vulnerability exists in electerm's file system operations (rmrf, mv, cp) in src/app/lib/fs.js. These functions construct shell commands by interpolating file paths directly into command strings without escaping shell metacharacters.

Vulnerable functions:

  • rmrf() - Uses rm -rf "${path}" (double quotes, vulnerable to " injection)
  • mv() - Uses mv '${from}' '${to}' (single quotes, vulnerable to ' injection)
  • cp() - Uses cp -r "${from}" "${to}" (double quotes, vulnerable to " injection)

Attack scenario:

  1. Attacker controls a malicious SSH/SFTP server
  2. Server lists files with shell metacharacters in names (e.g., file"$(touch /tmp/pwned)")
  3. Victim connects to the server and performs file operations (remote-to-local transfer, rename on conflict, etc.)
  4. The malicious filename is passed to rmrf(), mv(), or cp() without sanitization
  5. Shell metacharacters break out of the quoted argument and execute arbitrary commands

Impact includes:

  • Arbitrary command execution as the electerm desktop user
  • Data exfiltration, malware installation, or system compromise
  • Both POSIX (bash) and Windows (PowerShell) platforms are affected

Patches

Workarounds

If upgrading is not immediately possible, users can mitigate this vulnerability by:

  1. Only connecting to trusted SSH/SFTP servers
  2. Avoiding remote-to-local file transfers from untrusted sources
  3. Not using the "rename on conflict" option when downloading folders from untrusted servers
  4. Manually verifying filenames before performing file operations

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmelectermall versions3.11.11npm install electerm@3.11.11

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for electerm, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update electerm to 3.11.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-49255 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

### Impact A command injection vulnerability exists in electerm's file system operations (`rmrf`, `mv`, `cp`) in `src/app/lib/fs.js`. These functions construct shell commands by interpolating file paths directly into command strings without escaping shell metacharacters. **Vulnerable functions:** - `rmrf()` - Uses `rm -rf "${path}"` (double quotes, vulnerable to `"` injection) - `mv()` - Uses `mv '${from}' '${to}'` (single quotes, vulnerable to `'` injection) - `cp()` - Uses `cp -r "${from}" "${to}"` (double quotes, vulnerable to `"` injection) **Attack scenario:** 1. Attacker controls a ma
O3 Security · Impact-Aware SCA

Is CVE-2026-49255 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2026-49255: electerm — Fixed in 3.11.11