CVE-2026-47262 — containerd
CVE-2026-47262 is a Uncontrolled Resource Consumption vulnerability in github.com/containerd/containerd/v2. A fix is available for github.com/containerd/containerd/v2 — see the affected versions and patch details below.
containerd image-triggered runtime DoS via unbounded group parsing
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-47262.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
github.com/containerd/containerd/v2🐹github.com/containerd/containerd🐹github.com/containerd/containerd/v2🐹github.com/containerd/containerd/v2🐹github.com/containerd/containerd/v2Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A vulnerability in containerd allows a maliciously crafted image to cause a Denial of Service (DoS) condition. When creating a container from this image, memory exhaustion occurs, leading to an Out Of Memory (OOM) kill of the containerd process. This renders the container runtime API unavailable and can disrupt clients such as the Docker Engine or Kubernetes control-plane components.
Patches
This bug has been fixed in the following containerd versions:
- 2.3.2
- 2.2.5
- 2.1.9
- 2.0.10
- 1.7.33
Users should update to these versions to resolve the issue.
Workarounds
Ensure that only trusted images are used and that only trusted users have permissions to import images or schedule pods.
Credits
The containerd project would like to thank Jakub Ciolek (@jake-ciolek) at AlphaSense and Kyle Elliott @ Trail of Bits who independently discovered and responsibly disclosed this issue in accordance with the containerd security policy.
For more information
If you have any questions or comments about this advisory:
- Open an issue in containerd
- Email us at [email protected]
To report a security issue in containerd:
- Report a new vulnerability
- Email us at [email protected]
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/containerd/containerd/v2 | ≥ 2.0.0&&< 2.0.10 | 2.0.10go get github.com/containerd/containerd/v2@v2.0.10 |
| 🐹Go | github.com/containerd/containerd | ≥ 1.7.0&&< 1.7.33 | 1.7.33go get github.com/containerd/containerd@v1.7.33 |
| 🐹Go | github.com/containerd/containerd/v2 | ≥ 2.1.0&&< 2.1.9 | 2.1.9go get github.com/containerd/containerd/v2@v2.1.9 |
| 🐹Go | github.com/containerd/containerd/v2 | ≥ 2.2.0&&< 2.2.5 | 2.2.5go get github.com/containerd/containerd/v2@v2.2.5 |
| 🐹Go | github.com/containerd/containerd/v2 | ≥ 2.3.0&&< 2.3.2 | 2.3.2go get github.com/containerd/containerd/v2@v2.3.2 |
Affected Products
containerdlinuxfoundationDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/containerd/containerd/v2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/containerd/containerd/v2 to 2.0.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-47262 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat's container platform uses CRI-O as its container runtime interface, not containerd. While containerd libraries are bundled in some images for OCI image operations (e.g., estargz support via skopeo), the containerd daemon and its CRI plugin (where the vulnerable group-parsing code path exists) are not executed.…
No mitigation is needed for Red Hat products. The vulnerable code path in containerd's CRI plugin group-parsing logic is not executed because Red Hat uses CRI-O as the container runtime. Products that bundle containerd as a library dependency for OCI image operations are not affected.Source: Red Hat security advisory for CVE-2026-47262 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Hardened Images | kubernetes1-35-main-1.35.6-1.hum1 | RHSA-2026:25535 |
| Red Hat Hardened Images | kubernetes1-36-main-1.36.2-2.hum1 | RHSA-2026:26990 |
| Red Hat Hardened Images | opentelemetry-collector-contrib-main-0.155.0-0.1.hum1 | RHSA-2026:29770 |
| Red Hat Hardened Images | grype-main-0.115.0-0.1.hum1 | RHSA-2026:32963 |
| Red Hat Hardened Images | syft-main-1.46.0-0.1.hum1 | RHSA-2026:32974 |
| Red Hat Hardened Images | trivy-main-0.72.0-0.1.hum1 | RHSA-2026:35111 |
Frequently Asked Questions
Is CVE-2026-47262 in your dependencies?
Find it across Go, including transitive dependencies.