NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2026-42509 — wicket-parent

MEDIUM

CVE-2026-42509 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.apache.wicket:wicket-parent. A fix is available for org.apache.wicket:wicket-parent — see the affected versions and patch details below.

Apache Wicket: crafted strings can break out of the JavaScript sequence

Also known asGHSA-5x9h-93gp-chpj
Published
Updated
Affected
3 pkgs
Patched
1 / 3
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-42509.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs30th percentile — riskier than 30% of all scored CVEsHighest risk
0.00%0.36%0.72%1.07%0.2%0.4%Jun 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕org.apache.wicket:wicket-parent☕org.apache.wicket:wicket-parent☕org.apache.wicket:wicket-parent

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket.

This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0.

Users are recommended to upgrade to version 10.9.0, which fixes the issue.

Affected Packages

3 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.wicket:wicket-parent≥ 8.0.0-M1No fix
☕Mavenorg.apache.wicket:wicket-parent≥ 9.0.0-M1No fix
☕Mavenorg.apache.wicket:wicket-parent≥ 10.0.0-M1&&< 10.9.010.9.0org.apache.wicket:wicket-parent:10.9.0

Affected Products

1 product · 3 configurations
Application
wicketapache
≥ 10.0.0 && ≤ 9.22.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.wicket:wicket-parent, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2026-42509; check the affected-versions list above or the advisory for the patched release of org.apache.wicket:wicket-parent, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket. This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0. Users are recommended to upgrade to version 10.9.0, which fixes the issue.
O3 Security · Impact-Aware SCA

Is CVE-2026-42509 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2026-42509: wicket-parent XSS — Fixed in 10.9.0