CVE-2026-42282 is a medium-severity (CVSS 4.3) CWE-532 vulnerability in n8n-mcp. A fix is available for n8n-mcp — see the affected versions and patch details below.
n8n-MCP: Sensitive MCP tool-call arguments logged on authenticated requests in HTTP mode
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-42282.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
n8n-mcpnpmDescription
Impact
When n8n-mcp runs in HTTP transport mode, authenticated MCP tools/call requests had their full arguments and JSON-RPC params written to server logs by the request dispatcher and several sibling code paths before any redaction. When a tool call carries credential material — most notably n8n_manage_credentials.data — the raw values can be persisted in logs.
In deployments where logs are collected, forwarded to external systems, or viewable outside the request trust boundary (shared log storage, SIEM pipelines, support/ops access), this can result in disclosure of:
- bearer tokens and OAuth credentials sent through
n8n_manage_credentials - per-tenant API keys and webhook auth headers embedded in tool arguments
- arbitrary secret-bearing payloads passed to any MCP tool
The issue requires authentication (AUTH_TOKEN accepted by the server), so unauthenticated callers cannot trigger it; the runtime exposure is also reduced by an existing console-silencing layer in HTTP mode, but that layer is fragile and the values are still constructed and passed into the logger. The fix removes the leak at the source.
Impact category: CWE-532 (Insertion of Sensitive Information into Log File). CVSS 3.1 score: 4.3 Medium (AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N).
Affected
Deployments running n8n-mcp v2.47.12 or earlier in HTTP transport mode (MCP_MODE=http). The stdio transport short-circuits the relevant log calls and is not affected in practice.
Patched
v2.47.13 and later.
- npm:
npx n8n-mcp@latest(or pin to>= 2.47.13) - Docker:
docker pull ghcr.io/czlonkowski/n8n-mcp:latest
The patch routes tool-call arguments through a metadata-only summarizer (summarizeToolCallArgs) that records type, top-level key names, and approximate size — never values. The same pattern was adopted earlier for HTTP request bodies in GHSA-pfm2-2mhg-8wpx.
Workarounds
If developers cannot upgrade immediately:
- Restrict access to the HTTP port (firewall, reverse proxy, or VPN) so only trusted clients can authenticate.
- Restrict access to server logs (no shared SIEM ingestion, no support read-only access) until the upgrade lands.
- Switch to stdio transport (
MCP_MODE=stdio, the default for CLI invocation), which has no HTTP surface and short-circuits the affected log calls.
Credit
n8n-MCP thanks @Mirr2 (Organization / Jormungandr) for reporting this issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | n8n-mcp | all versions | 2.47.13npm install n8n-mcp@2.47.13 |
Affected Products
n8n-mcpn8n-mcpDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for n8n-mcp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update n8n-mcp to 2.47.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-42282 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2026-42282 in your dependencies?
Find it across npm, including transitive dependencies.