NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2026-41501 — electerm

CRITICALFix: electerm/electerm@59708b3

CVE-2026-41501 is a critical-severity (CVSS 9.8) CWE-77 vulnerability in electerm. A fix is available for electerm — see the affected versions and patch details below.

electerm has Command Injection Vulnerability via runLinux function

Also known asGHSA-8x35-hph8-37hq
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-41501.

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs70th percentile — riskier than 70% of all scored CVEsHighest risk
0.23%1.16%2.09%3.01%0.8%1.3%Jun 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

0other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
electermnpm
2Kdownloads / week

Description

Impact

What kind of vulnerability is it? Who is impacted?

Command Injection vulnerabilities in electerm:

A command injection vulnerability exists in github.com/elcterm/electerm/npm/install.js:130. The runLinux() function appends attacker-controlled remote version strings directly into an exec("rm -rf ...") command without validation.

Who is impacted: Users who run npm install -g electerm in Linux. An attacker who can control the remote release metadata (version string or release name) served by the project's update server could execute arbitrary system commands, tamper local files, and escalate compromise of development/runtime assets.


Patches

Has the problem been patched? What versions should users upgrade to?

Fixed in 59708b38c8a52f5db59d7d4eff98e31d573128ee, user no need to upgrade, the new version already published in npm


Workarounds

Is there a way for users to fix or remediate the vulnerability without upgrading?

no

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmelectermall versions3.3.8npm install electerm@3.3.8

Affected Products

1 product · 1 configurations
Application
electermelecterm_project
< 3.3.8
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for electerm, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update electerm to 3.3.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-41501 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

### Impact _What kind of vulnerability is it? Who is impacted?_ **Command Injection vulnerabilities in electerm:** A command injection vulnerability exists in `github.com/elcterm/electerm/npm/install.js:130`. The `runLinux()` function appends attacker-controlled remote version strings directly into an `exec("rm -rf ...")` command without validation. **Who is impacted:** Users who run `npm install -g electerm` in Linux. An attacker who can control the remote release metadata (version string or release name) served by the project's update server could execute arbitrary system commands, tamper
O3 Security · Impact-Aware SCA

Is CVE-2026-41501 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2026-41501: electerm — Fixed in 3.3.8