CVE-2026-41423 — @angular/platform-server
Fix: angular/angular@ede7c58CVE-2026-41423 is a Server-Side Request Forgery (SSRF) vulnerability in @angular/platform-server. A fix is available for @angular/platform-server — see the affected versions and patch details below.
Angular: SSRF via protocol-relative and backslash URLs in Angular Platform-Server
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-41423.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@angular/platform-servernpmDescription
Impact
A Server-Side Request Forgery (SSRF) vulnerability exists in @angular/platform-server due to improper handling of URLs during Server-Side Rendering (SSR).
When an attacker sends a request such as GET /\evil.com/ HTTP/1.1 the server engine (Express, etc.) passes the URL string to Angular’s rendering functions.
Because the URL parser normalizes the backslash to a forward slash for HTTP/HTTPS schemes, the internal state of the application is hijacked to believe the current origin is evil.com. This misinterpretation tricks the application into treating the attacker’s domain as the local origin. Consequently, any relative HttpClient requests or PlatformLocation.hostname references are redirected to the attacker controlled server, potentially exposing internal APIs or metadata services.
Affected APIs:
renderModulerenderApplicationCommonEngine(from@angular/ssr)
Non-Affected APIs:
AngularAppEngine(from@angular/ssr)AngularNodeAppEngine(from@angular/ssr)
Attack Preconditions
- The server has outbound network access.
- The application uses Angular SSR via the affected APIs.
- A pathname is passed as URL to the rendering method (e.g. using
req.url). - The server-side code performs HTTP requests using
HttpClientwith relative URLs or usesPlatformLocation.hostnameto build URLs.
Patches
- 22.0.0-next.8
- 21.2.9
- 20.3.19
- 19.2.21
Workarounds
Developers should implement a middleware to sanitize the request URL before it reaches Angular. This involves stripping or normalizing leading slashes:
app.use((req, res, next) => {
// Sanitize the URL to ensure it starts with a single forward slash
if (req.url.startsWith('//') || req.url.startsWith('/\\') || req.url.startsWith('\\')) {
req.url = '/' + req.url.replace(/^[/\\]+/, '');
}
next();
});
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @angular/platform-server | ≥ 22.0.0-next.0&&< 22.0.0-next.8 | 22.0.0-next.8npm install @angular/platform-server@22.0.0-next.8 |
| 📦npm | @angular/platform-server | ≥ 21.0.0-next.0&&< 21.2.9 | 21.2.9npm install @angular/platform-server@21.2.9 |
| 📦npm | @angular/platform-server | ≥ 20.0.0-next.0&&< 20.3.19 | 20.3.19npm install @angular/platform-server@20.3.19 |
| 📦npm | @angular/platform-server | ≥ 19.0.0-next.0&&< 19.2.21 | 19.2.21npm install @angular/platform-server@19.2.21 |
| 📦npm | @angular/platform-server | all versions | No fix |
Affected Products
angularangularDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @angular/platform-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @angular/platform-server to 22.0.0-next.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-41423 is resolved across your whole dependency graph.
Workarounds
Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.
Frequently Asked Questions
Is CVE-2026-41423 in your dependencies?
Find it across npm, including transitive dependencies.