CVE-2026-41128 — cms
Fix: craftcms/cms@b135384CVE-2026-41128 is a CWE-862 vulnerability in craftcms/cms. A fix is available for craftcms/cms — see the affected versions and patch details below.
Craft CMS has a Missing Authorization Check on User Group Removal via save-permissions Action
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-41128.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
craftcms/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Summary
The actionSavePermissions() endpoint allows a user with only viewUsers permission to remove arbitrary users from all user groups. While _saveUserGroups() enforces per-group authorization for additions, it performs no equivalent authorization check for removals, so submitting an empty groups value removes all existing group memberships.
Affected Versions
- Craft CMS 5.6.0 through 5.9.14 (latest release at time of report)
- Regression introduced in 5.6.0 when the
viewUserspermission was added - Prior to 5.6.0,
editedUser()requirededitUsers, which implicitly protected this endpoint - Requires Pro edition or higher (the vulnerable code path is gated by
CmsEdition::Pro)
Vulnerability Details
Root Cause
This is a regression introduced in Craft CMS 5.6.0 when the viewUsers permission was added. Before that change, editedUser() required editUsers permission for accessing other users’ data, which implicitly protected actionSavePermissions(). After the change, actionSavePermissions() became reachable for users with read-only access to other users, but the underlying group-saving logic still lacked authorization for group removals.
The vulnerability has two components:
-
actionSavePermissions()reachable with read-only access: The action only requires a control panel request and delegates toeditedUser(), which now only checksviewUsers— a permission explicitly documented as "read-only access to user elements." -
Asymmetric authorization in
_saveUserGroups(): The method checksassignUserGrouppermission only when adding a user to a new group. When thegroupsparameter is an empty string (resulting in an empty array), the loop is skipped entirely, no authorization checks are run, and all group memberships are removed.
Prerequisites
- Attacker has a control panel account with
accessCpandviewUserspermissions only - Target user belongs to one or more user groups that grant additional permissions
- Pro edition or higher
Attack Steps
- Attacker authenticates to the Control Panel
- Attacker sends a POST request to
actions/users/save-permissionswith:userId= target user's IDgroups= `` (empty string)
- All group memberships for the target user are removed
- All permissions inherited from those groups are immediately revoked
Impact
- Privilege revocation: An attacker can strip group-based permissions from arbitrary users, including accounts whose effective access derives from group membership
- Denial of access: Users lose access to sections, volumes, and features that were granted through group membership
- Bypass of elevated session requirement: Group removal does not trigger
requireElevatedSession()(which is only triggered when new groups are added)
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | craftcms/cms | ≥ 5.6.0&&< 5.9.15 | 5.9.15composer require craftcms/cms:^5.9.15 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for craftcms/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update craftcms/cms to 5.9.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-41128 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2026-41128 in your dependencies?
Find it across Packagist, including transitive dependencies.