CVE-2026-41004 — spring-cloud-config-server
MEDIUMCVE-2026-41004 is a medium-severity (CVSS 4.4) CWE-532 vulnerability in org.springframework.cloud:spring-cloud-config-server. A fix is available for org.springframework.cloud:spring-cloud-config-server — see the affected versions and patch details below.
Spring Cloud Config Server Logged Sensitive Information
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-41004.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.springframework.cloud:spring-cloud-config-server☕org.springframework.cloud:spring-cloud-config-server☕org.springframework.cloud:spring-cloud-config-server☕org.springframework.cloud:spring-cloud-config-server☕org.springframework.cloud:spring-cloud-config-server☕org.springframework.cloud:spring-cloud-config-serverReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
When trace logging is enabled in Spring Cloud Config Server, sensitive information is placed in plain text in the logs.
- Spring Cloud Config 3.0.x: affected from 3.0.0 through 3.0.7 (inclusive); no open-source upgrade available.
- Spring Cloud Config 3.1.x: affected from 3.1.0 through 3.1.13 (inclusive); no open-source upgrade available.
- Spring Cloud Config 4.1.x: affected from 4.1.0 through 4.1.9 (inclusive); no open-source upgrade available.
- Spring Cloud Config 4.2.x: affected from 4.2.0 through 4.2.6 (inclusive); no open-source upgrade available.
- Spring Cloud Config 4.3.x: affected from 4.3.0 through 4.3.2 (inclusive); upgrade to 4.3.3 or greater.
- Spring Cloud Config 5.0.x: affected from 5.0.0 through 5.0.2 (inclusive); upgrade to 5.0.3 or greater.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.springframework.cloud:spring-cloud-config-server | ≥ 3.1.0 | No fix |
| ☕Maven | org.springframework.cloud:spring-cloud-config-server | ≥ 4.1.0 | No fix |
| ☕Maven | org.springframework.cloud:spring-cloud-config-server | ≥ 4.2.0 | No fix |
| ☕Maven | org.springframework.cloud:spring-cloud-config-server | ≥ 4.3.0&&< 4.3.3 | 4.3.3org.springframework.cloud:spring-cloud-config-server:4.3.3 |
| ☕Maven | org.springframework.cloud:spring-cloud-config-server | ≥ 5.0.0&&< 5.0.3 | 5.0.3org.springframework.cloud:spring-cloud-config-server:5.0.3 |
| ☕Maven | org.springframework.cloud:spring-cloud-config-server | ≥ 3.0.0 | No fix |
Affected Products
spring cloud configvmwareDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework.cloud:spring-cloud-config-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
A fix is available for CVE-2026-41004; check the affected-versions list above or the advisory for the patched release of org.springframework.cloud:spring-cloud-config-server, then make sure no transitive dependency still pins the vulnerable range.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2026-41004 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2026-41004 in your dependencies?
Find it across Maven, including transitive dependencies.