CVE-2026-40682 — opennlp-tools
CRITICALCVE-2026-40682 is a critical-severity (CVSS 9.1) XML External Entity (XXE) vulnerability in org.apache.opennlp:opennlp-tools. A fix is available for org.apache.opennlp:opennlp-tools — see the affected versions and patch details below.
Apache OpenNLP: XXE via Dictionary Parsing in DictionaryEntryPersistor
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-40682.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.opennlp:opennlp-tools☕org.apache.opennlp:opennlp-tools☕org.apache.opennlp:opennlp-toolsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
XML External Entity (XXE) via Unsanitized Dictionary Parsing in Apache OpenNLP DictionaryEntryPersistor
Versions Affected: before 2.5.9, before 3.0.0-M3
Description: The DictionaryEntryPersistor class initializes a static SAXParserFactory at class-load time without enabling FEATURE_SECURE_PROCESSING or disabling DTD processing. When create(InputStream, EntryInserter) is invoked, the only feature set on the XMLReader is namespace support — external entity resolution and DOCTYPE declarations remain fully enabled. An attacker who can supply a crafted dictionary file (e.g., a stop-word list or domain dictionary) containing a malicious DOCTYPE declaration can trigger local file disclosure via file:// entity references or server-side request forgery via http:// entity references during SAX parsing, before the application processes a single dictionary entry. This is inconsistent with the project's own XmlUtil.createSaxParser() helper, which correctly sets FEATURE_SECURE_PROCESSING and disallow-doctype-decl and is used by all other XML parsing paths in the codebase. The public Dictionary(InputStream) constructor delegates directly to this method and is the documented API for loading user-supplied dictionaries, making untrusted input a realistic scenario.
Mitigation: 2.x users should upgrade to 2.5.9. 3.x users should upgrade to 3.0.0-M3. Users who cannot upgrade immediately should ensure that all dictionary files are sourced from trusted origins and should consider wrapping the Dictionary(InputStream) constructor with input validation that rejects any XML containing a DOCTYPE declaration before it reaches the parser.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.opennlp:opennlp-tools | ≥ 2.0.0&&< 2.5.9 | 2.5.9org.apache.opennlp:opennlp-tools:2.5.9 |
| ☕Maven | org.apache.opennlp:opennlp-tools | ≥ 3.0.0-M1&&< 3.0.0-M3 | 3.0.0-M3org.apache.opennlp:opennlp-tools:3.0.0-M3 |
| ☕Maven | org.apache.opennlp:opennlp-tools | all versions | 1.9.5org.apache.opennlp:opennlp-tools:1.9.5 |
Affected Products
opennlpapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.opennlp:opennlp-tools, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.opennlp:opennlp-tools to 2.5.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-40682 is resolved across your whole dependency graph.
Workarounds
Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Severity: Important This issue requires a vulnerable product to parse an attacker-controlled OpenNLP dictionary. The vulnerable parser can disclose local files or cause server-side requests. The CVSS vector requires neither privileges nor user interaction once that parsing path is reached. This potential…
For affected deployments that process dictionary XML from untrusted sources, use only trusted dictionary files. If untrusted dictionary input must be processed, reject documents containing a DOCTYPE declaration before passing them to OpenNLP’s dictionary parser.Source: Red Hat security advisory for CVE-2026-40682 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenShift AI 2.25 | rhoai/odh-trustyai-service-rhel9:1790933094 | RHSA-2026:87410 |
| Red Hat OpenShift AI 3.4 | rhoai/odh-trustyai-service-rhel9:1791792525 | RHSA-2026:84734 |
Frequently Asked Questions
Is CVE-2026-40682 in your dependencies?
Find it across Maven, including transitive dependencies.