CVE-2017-12620 — opennlp-tools
CRITICALCVE-2017-12620 is a critical-severity (CVSS 9.8) XML External Entity (XXE) vulnerability in org.apache.opennlp:opennlp-tools. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.apache.opennlp:opennlp-tools — see the affected versions and patch details below.
Improper Restriction of XML External Entity Reference in Apache OpenNLP
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.opennlp:opennlp-toolsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
When loading models or dictionaries that contain XML it is possible to perform an XXE attack, since Apache OpenNLP is a library, this only affects applications that load models or dictionaries from untrusted sources. The versions 1.5.0 to 1.5.3, 1.6.0, 1.7.0 to 1.7.2, 1.8.0 to 1.8.1 of Apache OpenNLP are affected.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.opennlp:opennlp-tools | ≥ 1.5.0&&< 1.8.2 | 1.8.2org.apache.opennlp:opennlp-tools:1.8.2 |
Affected Products
opennlpapacheResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.opennlp:opennlp-tools, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.opennlp:opennlp-tools to 1.8.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-12620 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2017-12620 in your dependencies?
Find it across Maven, including transitive dependencies.