CVE-2026-40542 is a high-severity (CVSS 7.3) CWE-304 vulnerability in org.apache.httpcomponents.client5:httpclient5. A fix is available for org.apache.httpcomponents.client5:httpclient5 — see the affected versions and patch details below.
Apache HttpClient: SCRAM-SHA-256 mutual authentication bypass may cause the client to accept authentication without proper mutual authentication verification
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-40542.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.httpcomponents.client5:httpclient5Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Missing critical step in authentication in Apache HttpClient 5.6 allows an attacker to cause the client to accept SCRAM-SHA-256 authentication without proper mutual authentication verification. Users are recommended to upgrade to version 5.6.1, which fixes this issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.httpcomponents.client5:httpclient5 | ≥ 5.6-alpha1&&< 5.6.1 | 5.6.1org.apache.httpcomponents.client5:httpclient5:5.6.1 |
Affected Products
httpclientapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.httpcomponents.client5:httpclient5, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.httpcomponents.client5:httpclient5 to 5.6.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-40542 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| OpenShift Developer Tools and Services 4.12 | ocp-tools-4/jenkins-rhel8:1786628667 | RHSA-2026:60247 |
| OpenShift Developer Tools and Services 4.13 | ocp-tools-4/jenkins-rhel8:1786628681 | RHSA-2026:60249 |
| OpenShift Developer Tools and Services 4.14 | ocp-tools-4/jenkins-rhel8:1786533561 | RHSA-2026:60248 |
| OpenShift Developer Tools and Services 4.15 | ocp-tools-4/jenkins-rhel8:1786533565 | RHSA-2026:60239 |
| OpenShift Developer Tools and Services 4.16 | ocp-tools-4/jenkins-rhel9:1787125166 | RHSA-2026:60251 |
| OpenShift Developer Tools and Services 4.17 | ocp-tools-4/jenkins-rhel9:1787124635 | RHSA-2026:60246 |
| OpenShift Developer Tools and Services 4.18 | ocp-tools-4/jenkins-rhel9:1787125069 | RHSA-2026:60250 |
| OpenShift Developer Tools and Services 4.19 | ocp-tools-4/jenkins-rhel9:1787124632 | RHSA-2026:60252 |
Frequently Asked Questions
Is CVE-2026-40542 in your dependencies?
Find it across Maven, including transitive dependencies.