CVE-2026-40010 — wicket-auth-roles
CRITICALCVE-2026-40010 is a critical-severity (CVSS 9.1) CWE-384 vulnerability in org.apache.wicket:wicket-auth-roles. A fix is available for org.apache.wicket:wicket-auth-roles — see the affected versions and patch details below.
Apache Wicket: possible session fixation using AuthenticatedWebSession
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-40010.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.wicket:wicket-auth-roles☕org.apache.wicket:wicket-auth-roles☕org.apache.wicket:wicket-auth-rolesReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Missing invocation of Servlet http web request method changeSessionId after session binding can be exploited for a session fixation attack in Apache Wicket.
This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0.
Users are recommended to upgrade to version 10.9.0, which fixes the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.wicket:wicket-auth-roles | ≥ 8.0.0-M1 | No fix |
| ☕Maven | org.apache.wicket:wicket-auth-roles | ≥ 9.0.0-M1 | No fix |
| ☕Maven | org.apache.wicket:wicket-auth-roles | ≥ 10.0.0-M1&&< 10.9.0 | 10.9.0org.apache.wicket:wicket-auth-roles:10.9.0 |
Affected Products
wicketapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.wicket:wicket-auth-roles, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
A fix is available for CVE-2026-40010; check the affected-versions list above or the advisory for the patched release of org.apache.wicket:wicket-auth-roles, then make sure no transitive dependency still pins the vulnerable range.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2026-40010 in your dependencies?
Find it across Maven, including transitive dependencies.