CVE-2026-39363 — vite
Fix: vitejs/vite#22159CVE-2026-39363 is a Information Exposure vulnerability in vite. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for vite — see the affected versions and patch details below.
Vite Affected by Arbitrary File Read via Vite Dev Server WebSocket
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-39363.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
vitenpmDescription
Summary
server.fs check was not enforced to the fetchModule method that is exposed in Vite dev server's WebSocket.
Impact
Only apps that match the following conditions are affected:
- explicitly exposes the Vite dev server to the network (using
--hostorserver.hostconfig option) - WebSocket is not disabled by
server.ws: false
Arbitrary files on the server (development machine, CI environment, container, etc.) can be exposed.
Details
If it is possible to connect to the Vite dev server’s WebSocket without an Origin header, an attacker can invoke fetchModule via the custom WebSocket event vite:invoke and combine file://... with ?raw (or ?inline) to retrieve the contents of arbitrary files on the server as a JavaScript string (e.g., export default "...").
The access control enforced in the HTTP request path (such as server.fs.allow) is not applied to this WebSocket-based execution path.
PoC
-
Start the dev server on the target Example (used during validation with this repository):
pnpm -C playground/alias exec vite --host 0.0.0.0 --port 5173 -
Confirm that access is blocked via the HTTP path (example: arbitrary file)
curl -i 'http://localhost:5173/@fs/etc/passwd?raw'Result:
403 Restricted(outside the allow list) <img width="3898" height="1014" alt="image" src="https://github.com/user-attachments/assets/f6593377-549c-45d7-b562-5c19833438af" /> -
Confirm that the same file can be retrieved via the WebSocket path By connecting to the HMR WebSocket without an
<img width="1049" height="296" alt="image" src="https://github.com/user-attachments/assets/af969f7b-d34e-4af4-8adb-5e2b83b31972" />Originheader and sending avite:invokerequest that callsfetchModulewith afile://...URL and?raw, the file contents are returned as a JavaScript module.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | vite | ≥ 8.0.0&&< 8.0.5 | 8.0.5npm install vite@8.0.5 |
| 📦npm | vite | ≥ 7.0.0&&< 7.3.2 | 7.3.2npm install vite@7.3.2 |
| 📦npm | vite | ≥ 6.0.0&&< 6.4.2 | 6.4.2npm install vite@6.4.2 |
Affected Products
vitevitejsvite\+voidzeroResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for vite, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update vite to 8.0.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-39363 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2026-39363 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Ansible Automation Platform 2.5 for RHEL 8 | automation-gateway-0:2.5.20260422-3.el8ap | RHSA-2026:24761 |
| Red Hat Ansible Automation Platform 2.6 for RHEL 9 | automation-platform-ui-0:2.6.9-1.el9ap | RHSA-2026:24762 |
| Red Hat Ansible Automation Platform 2.6 | ansible-automation-platform-tech-preview/mcp-server-rhel9:1779783248 | RHSA-2026:24866 |
| Red Hat Ansible Automation Platform 2.7 | ansible-automation-platform-27/gateway-rhel9:1787218409 | RHSA-2026:59153 |
Frequently Asked Questions
Is CVE-2026-39363 in your dependencies?
Find it across npm, including transitive dependencies.