CVE-2026-35536 is a high-severity (CVSS 7.2) CWE-159 vulnerability in tornado. A fix is available for tornado — see the affected versions and patch details below.
Tornado has incomplete validation of cookie attributes
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-35536.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
tornadoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Values passed to the domain, path, and samesite arguments of RequestHandler.set_cookie were not completely validated in versions of Tornado prior to 6.5.5. In particular, semicolons would be allowed, which could be used to inject attacker-controlled values for other cookie attributes.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | tornado | all versions | 6.5.5pip install --upgrade 'tornado==6.5.5' |
Affected Products
tornadotornadowebDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tornado, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update tornado to 6.5.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-35536 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This vulnerability is rated as Moderate because successful exploitation requires an application to pass untrusted, user-supplied data into cookie configuration parameters, limiting the risk in standard deployments. In typical Red Hat environments running Tornado web services, cookie attributes such as domain, path,…
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 10 | python-tornado-0:6.5.5-1.el10_1.1 | RHSA-2026:13641 |
| Red Hat Enterprise Linux 10 | python-tornado-0:6.5.5-1.el10_2 | RHSA-2026:19034 |
| Red Hat Enterprise Linux 10.0 Extended Update Support | python-tornado-0:6.4.2-1.el10_0.2 | RHSA-2026:20577 |
| Red Hat Enterprise Linux 7 Extended Lifecycle Support | python-tornado-0:4.2.1-5.el7_9.3 | RHSA-2026:24342 |
| Red Hat Enterprise Linux 9 | python-tornado-0:6.5.5-1.el9_7.1 | RHSA-2026:13670 |
| Red Hat Enterprise Linux 9 | python-tornado-0:6.5.5-1.el9_8 | RHSA-2026:19189 |
| Red Hat Enterprise Linux 9.2 Update Services for SAP Solutions | python-tornado-0:6.4.2-1.el9_2.2 | RHSA-2026:20573 |
| Red Hat Enterprise Linux 9.4 Extended Update Support | python-tornado-0:6.4.2-1.el9_4.2 | RHSA-2026:20810 |
Frequently Asked Questions
Is CVE-2026-35536 in your dependencies?
Find it across PyPI, including transitive dependencies.