NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2026-34557 — ci4ms

CRITICAL

CVE-2026-34557 is a critical-severity (CVSS 9.1) Cross-site Scripting (XSS) vulnerability in ci4-cms-erp/ci4ms. A fix is available for ci4-cms-erp/ci4ms — see the affected versions and patch details below.

CI4MS: Permissions Management Full Account Takeover for All-Roles & Privilege-Escalation via Stored DOM XSS

Also known asGHSA-rpjr-985c-qhvm
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-34557.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk-0.06%
Lower risk than most CVEs25th percentile — riskier than 25% of all scored CVEsHighest risk
0.00%0.29%0.59%0.88%0.0%0.3%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘ci4-cms-erp/ci4ms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Summary

Vulnerability: Stored DOM XSS via Group / Role Management Fields (Administrative Context Execution)

  • Stored Cross-Site Scripting via Unsanitized Group / Role Management Inputs

Description

The application fails to properly sanitize user-controlled input within group and role management functionality. Multiple input fields (three distinct group-related fields) can be injected with malicious JavaScript payloads, which are then stored server-side.

These stored payloads are later rendered unsafely within privileged administrative views without proper output encoding, leading to stored cross-site scripting (XSS) within the role and permission management context.

Affected Functionality

  • Group creation and editing functionality
  • Role and permission assignment interfaces
  • Storage and retrieval of group-related data

Attack Scenario

  • An attacker injects a malicious XSS payload into one or more group-related input fields.
  • The application stores these values without sanitization or encoding.
  • An administrator views the group or role management interface.
  • The payload executes automatically in the administrator’s browser.

Impact

  • Persistent Stored XSS
  • Execution of arbitrary JavaScript in victims’ browsers
  • Privilege escalation when viewed by administrators
  • Full administrator account takeover
  • Full compromise of the entire application

Endpoints:

  • /backend/users/groupList/

Steps To Reproduce (POC)

  1. Navigate to the Group / Role Management page
  2. Insert an XSS payload into any of the three group-related input fields such as: <img src=x onerror=alert(document.domain)>
  3. Save the group or role changes
  4. View the group/role management page as an administrator
  5. Observe the XSS payload executing automatically

Remediation

  • Never use .html() again or any innerHTML-style like JS in your PHP, or any other sink, even if user inputs that flow into them are not clear, they still represent real world danger as an attacker can make use of this to exploit the application via XSS. And do HTML Encoding as much as possible and always do Sanitization, theres no sanitization there unfortunately. Also apply CSP, HttpOnly, SameSite, and Secure upon all application, they reduce severity of XSS & escalated-CSRF via XSS and do great jobs

Ready Video POC:

https://mega.nz/file/6QUEXDbR#JXzYXg9bef_NeSUVFB4R03UeXLtAVtYwTRsdrHLlokU

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistci4-cms-erp/ci4msall versions0.31.0.0composer require ci4-cms-erp/ci4ms:^0.31.0.0

Affected Products

1 product · 1 configurations
Application
ci4msci4-cms-erp
< 0.31.0.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ci4-cms-erp/ci4ms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ci4-cms-erp/ci4ms to 0.31.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-34557 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

## Summary ### **Vulnerability: Stored DOM XSS via Group / Role Management Fields (Administrative Context Execution)** - Stored Cross-Site Scripting via Unsanitized Group / Role Management Inputs ### Description The application fails to properly sanitize user-controlled input within group and role management functionality. Multiple input fields (three distinct group-related fields) can be injected with malicious JavaScript payloads, which are then stored server-side. These stored payloads are later rendered unsafely within privileged administrative views without proper output encoding, leadi
O3 Security · Impact-Aware SCA

Is CVE-2026-34557 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2026-34557: ci4ms XSS — Fixed in 0.31.0.0