NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

CVE-2026-32898 — openclaw

Fix: openclaw/openclaw@12cc754

CVE-2026-32898 is a CWE-807 vulnerability in openclaw. A fix is available for openclaw — see the affected versions and patch details below.

OpenClaw < 2026.2.23 - ACP Permission Auto-Approval Bypass via Untrusted Tool Metadata

Also known asGHSA-7jx5-9fjg-hp4m
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 27, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-32898.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk-0.09%
Lower risk than most CVEs18th percentile — riskier than 18% of all scored CVEsHighest risk
0.00%0.28%0.57%0.85%0.1%0.3%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

132other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
openclawnpm
2.7Mdownloads / week

Description

Vulnerability Summary

The OpenClaw ACP client could auto-approve tool calls based on untrusted metadata and permissive name heuristics. A malicious or compromised ACP tool invocation could bypass expected interactive approval prompts for read-class operations.

Affected Packages / Versions

  • Package: npm openclaw
  • Affected published versions: <= 2026.2.22-2 (latest published as of February 24, 2026 is 2026.2.22-2)
  • Patched in code on main: 2026.2.23 (released)

Technical Details

  • Permission classification trusted incoming toolCall.kind and heuristic name matching.
  • Non-core read-like names and spoofed kind metadata could reach auto-approve paths.
  • read operations were not scoped strongly enough to cwd in all metadata/title forms.

Fix

  • Require trusted core tool IDs for auto-approval and ignore untrusted toolCall.kind as an authorization source.
  • Scope read auto-approval to cwd-resolved paths.
  • Add stricter tool-name validation and regression coverage for spoofed kind and non-core read-like names.

Affected Functions

  • resolvePermissionRequest
  • resolveToolNameForPermission
  • shouldAutoApproveToolCall

Fix Commit(s)

  • 12cc754332f9a7c92e158ce7644aa22df79c0904
  • 63dcd28ae0be2de1c75af09cc81841cebeec068f

Found using MCPwner

Thanks @nedlir for reporting.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmopenclawall versions2026.2.23npm install openclaw@2026.2.23

Affected Products

1 product · 1 configurations
Application
openclawopenclaw
< 2026.2.23
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openclaw, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update openclaw to 2026.2.23 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-32898 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

## Vulnerability Summary The OpenClaw ACP client could auto-approve tool calls based on untrusted metadata and permissive name heuristics. A malicious or compromised ACP tool invocation could bypass expected interactive approval prompts for read-class operations. ## Affected Packages / Versions - Package: npm `openclaw` - Affected published versions: `<= 2026.2.22-2` (latest published as of February 24, 2026 is `2026.2.22-2`) - Patched in code on `main`: `2026.2.23` (released) ## Technical Details - Permission classification trusted incoming `toolCall.kind` and heuristic name matching. -
O3 Security · Impact-Aware SCA

Is CVE-2026-32898 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2026-32898: openclaw — Fixed in 2026.2.23