NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🦀 crates.io
Not in CISA KEV

CVE-2026-32829 — lz4_flex

Fix: PSeitz/lz4_flex@055502e

CVE-2026-32829 is a CWE-201 vulnerability in lz4_flex. A fix is available for lz4_flex — see the affected versions and patch details below.

lz4_flex: Decompression can leak information from uninitialized memory or reused output buffer

Also known asGHSA-vvp9-7p8x-rfvvRUSTSEC-2026-0041
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-32829.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs50th percentile — riskier than 50% of all scored CVEsHighest risk
0.00%0.40%0.79%1.19%0.0%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
🦀lz4_flex🦀lz4_flex

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.

Description

Summary

Decompressing invalid LZ4 data can leak data from uninitialized memory, or can leak content from previous decompression operations when reusing an output buffer.

Details

The LZ4 block format defines a "match copy operation" which duplicates previously written data or data from the user-supplied dict. The position of that data is defined by an offset. The data is copied within the output buffer from the offset to the current output position. However, lz4_flex did not properly detect invalid and out-of-bounds offset values properly, causing it to copy uninitialized data from the output buffer.

Only the block based API functions are affected: lz4_flex::block::{decompress_into, decompress_into_with_dict}

When safe-decode is disabled additionally these functions are affected lz4_flex::block::{decompress, decompress_with_dict, decompress_size_prepended, decompress_size_prepended_with_dict}

All frame APIs are not affected.

There are two affected use cases:

  • decompressing LZ4 data with the unsafe implementation (safe-decode feature flag disabled, which is enabled by default): can leak content of uninitialized memory as decompressed result
  • decompressing LZ4 data into a reused, user-supplied output buffer (affects the safe-decode feature as well): can leak the previous contents of the output buffer as decompressed result

Impact

Leakage of data from uninitialized memory or content from previous decompression operations, possibly revealing sensitive information and secrets.

Mitigation

lz4_flex 0.12.1 and 0.11.6 fixes this issue without requiring changes in user code.

If you cannot upgrade, you can mitigate this vulnerability by zeroing the output buffer before calling block::decompress_into or block::decompress_into_with_dict (only block based API is affected, frame API is not affected). Additionally the the safe-decode feature flag should be enabled.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🦀crates.iolz4_flexall versions0.11.6cargo update -p lz4_flex --precise 0.11.6
🦀crates.iolz4_flex≥ 0.12.0&&< 0.12.10.12.1cargo update -p lz4_flex --precise 0.12.1

Affected Products

1 product · 2 configurations
Application
lz4 flexpseitz
< 0.11.6
1 version
0.12.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for lz4_flex, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update lz4_flex to 0.11.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-32829 is resolved across your whole dependency graph.

  3. Workarounds

    Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.

Frequently Asked Questions

### Summary Decompressing invalid LZ4 data can leak data from uninitialized memory, or can leak content from previous decompression operations when reusing an output buffer. ### Details The LZ4 block format defines a "match copy operation" which duplicates previously written data or data from the user-supplied dict. The position of that data is defined by an _offset_. The data is copied within the output buffer from the _offset_ to the current output position. However, lz4_flex did not properly detect invalid and out-of-bounds _offset_ values properly, causing it to copy uninitialized data fr
O3 Security · Impact-Aware SCA

Is CVE-2026-32829 in your dependencies?

Find it across crates.io, including transitive dependencies.

CVE-2026-32829: lz4_flex Info Disclosure — Fixed in 0.11.6