NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

CVE-2026-32732 — @leanprover/unicode-input…

Fix: leanprover/vscode-lean4#735

CVE-2026-32732 is a CWE-80 vulnerability in @leanprover/unicode-input-component. A fix is available for @leanprover/unicode-input-component — see the affected versions and patch details below.

XSS in @leanprover/unicode-input-component

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-32732.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs25th percentile — riskier than 25% of all scored CVEsHighest risk
0.00%0.34%0.68%1.02%0.1%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

0other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@leanprover/unicode-input-componentnpm
158downloads / week

Description

Impact

Projects that use @leanprover/unicode-input-component are vulnerable to an XSS exploit in 0.1.9 of the package and lower. The component re-inserted text in the input element back into the input element as unescaped HTML.

Patches

The issue has been resolved in 0.2.0.

Workarounds

Replace the unicode input component with a basic HTML text field.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@leanprover/unicode-input-componentall versions0.2.0npm install @leanprover/unicode-input-component@0.2.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @leanprover/unicode-input-component, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @leanprover/unicode-input-component to 0.2.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-32732 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

### Impact Projects that use [@leanprover/unicode-input-component](https://www.npmjs.com/package/@leanprover/unicode-input-component) are vulnerable to an XSS exploit in 0.1.9 of the package and lower. The component re-inserted text in the input element back into the input element as unescaped HTML. ### Patches The issue has been resolved in 0.2.0. ### Workarounds Replace the unicode input component with a basic HTML text field.
O3 Security · Impact-Aware SCA

Is CVE-2026-32732 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2026-32732: @leanprover/unicode — Fixed in 0.2.0