NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
LOW severity

CVE-2026-32722 — memray

LOWFix: bloomberg/memray@ba6e4e2

CVE-2026-32722 is a low-severity (CVSS 3.6) Cross-site Scripting (XSS) vulnerability in memray. A fix is available for memray — see the affected versions and patch details below.

Memray-generated HTML reports vulnerable to Stored XSS via unescaped command-line metadata

Also known asGHSA-r5pr-887v-m2w9PYSEC-2026-2203
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-32722.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk-0.04%
Lower risk than most CVEs24th percentile — riskier than 24% of all scored CVEsHighest risk
0.00%0.28%0.57%0.85%0.0%0.3%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍memray

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Summary

Prior to Memray 1.19.2, Memray rendered the command line of the tracked process directly into generated HTML reports without escaping. Because there was no escaping, attacker-controlled command line arguments were inserted as raw HTML into the generated report.

This allowed JavaScript execution when a victim opened the generated report in a browser.

Affected Version

  • Memray version: 1.19.1 and earlier

Remediation

Upgrade to Memray 1.19.2, and avoid attaching Memray to untrusted processes until you have upgraded.

Root Cause

Jinja is used to embed the process's command line arguments into the generated flame graph or table report. Memray has not been telling Jinja to HTML escape the command line arguments when writing them into the HTML, leading to a stored XSS vulnerability.

Impact

An attacker who can influence the script name or command-line arguments of a profiled program can inject HTML/JavaScript into Memray-generated HTML reports (both memray flamegraph and memray table reports, both with and without --no-web). When a victim opens the generated report in a browser, the injected JavaScript executes in the context of the report.

Note that in the case of memray attach, the user attaching Memray and generating the report may be a different user than the one who ran the command and set up the command line arguments.

Proof of Concept

Run Memray on a script with an attacker-controlled filename:

touch '<img src=x onerror=alert(1)>'
python -m memray run -o poc.bin '<img src=x onerror=alert(1)>'

Generate a report:

python -m memray flamegraph -o poc.html poc.bin

Observed Result

The generated HTML contains raw unescaped attacker-controlled HTML.

Opening or reloading the generated report in a browser triggers JavaScript execution.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImemrayall versions1.19.2pip install --upgrade 'memray==1.19.2'

Affected Products

1 product · 1 configurations
Application
memraybloomberg
< 1.19.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for memray, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update memray to 1.19.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-32722 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

## Summary Prior to Memray 1.19.2, Memray rendered the command line of the tracked process directly into generated HTML reports without escaping. Because there was no escaping, attacker-controlled command line arguments were inserted as raw HTML into the generated report. This allowed JavaScript execution when a victim opened the generated report in a browser. ## Affected Version - Memray version: `1.19.1` and earlier ## Remediation Upgrade to Memray 1.19.2, and avoid attaching Memray to untrusted processes until you have upgraded. ## Root Cause Jinja is used to embed the process's com
O3 Security · Impact-Aware SCA

Is CVE-2026-32722 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2026-32722: memray XSS — Fixed in 1.19.2