NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2026-30964 — webauthn-framework

MEDIUMFix: web-auth/webauthn-framework@535cc3c

CVE-2026-30964 is a medium-severity (CVSS 5.4) CWE-346 vulnerability in web-auth/webauthn-framework. A fix is available for web-auth/webauthn-framework — see the affected versions and patch details below.

Webauthn Framework: allowed_origins collapses URL-like origins to host-only values, bypassing exact origin validation

Also known asGHSA-f7pm-6hr8-7ggm
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-30964.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs11th percentile — riskier than 11% of all scored CVEsHighest risk
0.00%0.24%0.47%0.71%0.0%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘web-auth/webauthn-framework🐘web-auth/webauthn-lib🐘web-auth/webauthn-symfony-bundle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Summary

When allowed_origins is configured, CheckAllowedOrigins reduces URL-like values to their host component and accepts on host match alone. This makes exact origin policies impossible to express: scheme and port differences are silently ignored.

Details

CheckAllowedOrigins stores each configured allowed origin as:

parse_url($allowedOrigin)['host'] ?? $allowedOrigin

and later reduces the received clientDataJSON.origin the same way:

parse_url($C->origin)['host'] ?? $C->origin

If the reduced value matches, the method returns early. As a result, for the normal allowed_origins path, the later HTTPS check is not reached.

This differs from WebAuthn Level 2, which requires verifying that C.origin matches the RP's origin (scheme + host + port), separately from verifying that authData.rpIdHash matches the expected RP ID.

Affected code:

Spec references:

PoC

Configuration:

webauthn:
  allowed_origins:
    - https://login.example.com:8443
  allow_subdomains: false

Send a registration or authentication response whose clientDataJSON.origin is:

https://login.example.com:9443

Observed: the response is accepted, because both values are reduced to login.example.com.

Expected: the response should be rejected, because https://login.example.com:8443 and https://login.example.com:9443 are different origins.

Impact

This is an origin validation error (CWE-346) affecting deployments that use allowed_origins. The most practical browser-facing scenario is same-host / different-port origin confusion. In non-browser or custom clients, scheme confusion may also be relevant.

Fix

Fixed in version 5.2.4 by rewriting CheckAllowedOrigins to perform full origin comparison (scheme + host + port) as required by the WebAuthn spec:

  • Origins configured with a scheme (e.g. https://example.com:8443) are now stored and compared as full scheme://host[:port] values, with default port normalization (443 for HTTPS, 80 for HTTP).
  • Origins configured without a scheme are still matched by host only, for backward compatibility.
  • Subdomain matching now also verifies scheme and port consistency.

See commit b4cd9a43.

Mitigation

Upgrade to web-auth/webauthn-framework (or web-auth/webauthn-lib / web-auth/webauthn-symfony-bundle) >= 5.2.4.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistweb-auth/webauthn-framework≥ 5.2.0&&< 5.2.45.2.4composer require web-auth/webauthn-framework:^5.2.4
🐘Packagistweb-auth/webauthn-lib≥ 5.2.0&&< 5.2.45.2.4composer require web-auth/webauthn-lib:^5.2.4
🐘Packagistweb-auth/webauthn-symfony-bundle≥ 5.2.0&&< 5.2.45.2.4composer require web-auth/webauthn-symfony-bundle:^5.2.4

Affected Products

3 products · 3 configurations
Application
webauthn framworkspomky-labs
≥ 5.2.0 && < 5.2.4
range
Application
webauthn-libspomky-labs
≥ 5.2.0 && < 5.2.4
range
Application
webauthn-symfony-bundlespomky-labs
≥ 5.2.0 && < 5.2.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for web-auth/webauthn-framework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update web-auth/webauthn-framework to 5.2.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-30964 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Summary When `allowed_origins` is configured, `CheckAllowedOrigins` reduces URL-like values to their `host` component and accepts on host match alone. This makes exact origin policies impossible to express: scheme and port differences are silently ignored. ### Details `CheckAllowedOrigins` stores each configured allowed origin as: ```php parse_url($allowedOrigin)['host'] ?? $allowedOrigin ``` and later reduces the received `clientDataJSON.origin` the same way: ```php parse_url($C->origin)['host'] ?? $C->origin ``` If the reduced value matches, the method returns early. As a result, fo
O3 Security · Impact-Aware SCA

Is CVE-2026-30964 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2026-30964: webauthn-framework — Fixed in 5.2.4