NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
.NET
.NET NuGet
Not in CISA KEV
MEDIUM severity

CVE-2026-28686 — Magick.NET-Q16-AnyCPU

MEDIUM

CVE-2026-28686 is a medium-severity (CVSS 6.8) CWE-122 vulnerability in Magick.NET-Q16-AnyCPU. A fix is available for Magick.NET-Q16-AnyCPU — see the affected versions and patch details below.

ImageMagick has a write heap-buffer-overflow in PCL encoder via undersized output buffer

Also known asGHSA-467j-76j7-5885
Published
Updated
Affected
19 pkgs
Patched
19 / 19
Exploits
None indexed
Exploitation data as of Oct 27, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-28686.

EPSS Exploitation Probability

via FIRST.org ↗
0.1%probability of exploitation in next 30 days
Lower Risk-0.04%
Lower risk than most CVEs2th percentile — riskier than 2% of all scored CVEsHighest risk
0.00%0.22%0.44%0.66%0.0%0.1%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

19 pkgs affected
.NETMagick.NET-Q16-AnyCPU.NETMagick.NET-Q16-HDRI-AnyCPU.NETMagick.NET-Q16-HDRI-OpenMP-arm64.NETMagick.NET-Q16-HDRI-arm64.NETMagick.NET-Q16-HDRI-x64.NETMagick.NET-Q16-HDRI-x86.NETMagick.NET-Q16-OpenMP-arm64.NETMagick.NET-Q16-OpenMP-x64+11 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.

Description

ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to versions 7.1.2-16 and 6.9.13-41, A heap-buffer-overflow vulnerability exists in the PCL encode due to an undersized output buffer allocation. This vulnerability is fixed in 7.1.2-16 and 6.9.13-41.

Affected Packages

19 total 19 fixed
EcosystemPackageVulnerable rangeFix
.NETNuGetMagick.NET-Q16-AnyCPUall versions14.10.4dotnet add package Magick.NET-Q16-AnyCPU --version 14.10.4
.NETNuGetMagick.NET-Q16-HDRI-AnyCPUall versions14.10.4dotnet add package Magick.NET-Q16-HDRI-AnyCPU --version 14.10.4
.NETNuGetMagick.NET-Q16-HDRI-OpenMP-arm64all versions14.10.4dotnet add package Magick.NET-Q16-HDRI-OpenMP-arm64 --version 14.10.4
.NETNuGetMagick.NET-Q16-HDRI-arm64all versions14.10.4dotnet add package Magick.NET-Q16-HDRI-arm64 --version 14.10.4
.NETNuGetMagick.NET-Q16-HDRI-x64all versions14.10.4dotnet add package Magick.NET-Q16-HDRI-x64 --version 14.10.4
.NETNuGetMagick.NET-Q16-HDRI-x86all versions14.10.4dotnet add package Magick.NET-Q16-HDRI-x86 --version 14.10.4

Affected Products

1 product · 2 configurations
Application
imagemagickimagemagick
≥ 7.0.0-0 && < 7.1.2-16
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Magick.NET-Q16-AnyCPU, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update Magick.NET-Q16-AnyCPU to 14.10.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-28686 is resolved across your whole dependency graph.

  3. Workarounds

    Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

This MODERATE impact vulnerability in ImageMagick involves a heap-buffer-overflow within the PCL encoder. Processing a specially crafted image could trigger this flaw, potentially leading to denial of service or other impacts. This affects Red Hat Enterprise Linux 6 ELS and 7 ELS, as well as community projects like…

Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.
Source: Red Hat security advisory for CVE-2026-28686 (CC BY 4.0)

Frequently Asked Questions

ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to versions 7.1.2-16 and 6.9.13-41, A heap-buffer-overflow vulnerability exists in the PCL encode due to an undersized output buffer allocation. This vulnerability is fixed in 7.1.2-16 and 6.9.13-41.
O3 Security · Impact-Aware SCA

Is CVE-2026-28686 in your dependencies?

Find it across NuGet, including transitive dependencies.

CVE-2026-28686: Magick.NET-Q16 — Fixed in 14.10.4