NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

CVE-2026-27818 — terriajs-server

Fix: TerriaJS/terriajs-server@3aaa5d9

CVE-2026-27818 is a Improper Input Validation vulnerability in terriajs-server. A fix is available for terriajs-server — see the affected versions and patch details below.

TerriaJS-Server has a domain validation bypass vulnerability in its proxy allowlist

Also known asGHSA-w789-49fc-v8hr
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-27818.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk-0.13%
Lower risk than most CVEs21th percentile — riskier than 21% of all scored CVEsHighest risk
0.00%0.30%0.60%0.91%0.1%0.3%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

2other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
terriajs-servernpm
2Kdownloads / week

Description

Impact

A validation bug allows an attacker to proxy domains not explicitly allowed in the proxyableDomains configuration.

The validation only checks if a hostname ended with an allowed domain. This meant:

If example.com is allowed in proxyableDomains:

  • ✅ example.com is allowed (correct)
  • ✅ api.example.com is allowed (correct)
  • ⚠️ maliciousexample.com is allowed (incorrect)

An attacker could register maliciousexample.com and proxy content through terriajs-server, bypassing proxy restrictions.

Patches

All versions up to 4.0.2 are affected. Upgrade to 4.0.3 to address the vulnerability.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmterriajs-serverall versions4.0.3npm install terriajs-server@4.0.3

Affected Products

1 product · 1 configurations
Application
terriajs-serverterria
< 4.0.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for terriajs-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update terriajs-server to 4.0.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-27818 is resolved across your whole dependency graph.

  3. Workarounds

    Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.

Frequently Asked Questions

### Impact A validation bug allows an attacker to proxy domains not explicitly allowed in the `proxyableDomains` configuration. The validation only checks if a hostname _ended_ with an allowed domain. This meant: If `example.com` is allowed in `proxyableDomains`: - ✅ example.com is allowed (correct) - ✅ api.example.com is allowed (correct) - ⚠️ maliciousexample.com is allowed (incorrect) An attacker could register maliciousexample.com and proxy content through `terriajs-server`, bypassing proxy restrictions. ### Patches All versions up to 4.0.2 are affected. Upgrade to 4.0.3 to address th
O3 Security · Impact-Aware SCA

Is CVE-2026-27818 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2026-27818: terriajs-server — Fixed in 4.0.3