NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
.NET
.NET NuGet
Not in CISA KEV
MEDIUM severity

CVE-2026-27798 — Magick.NET-Q16-AnyCPU

MEDIUMFix: ImageMagick/ImageMagick@0377e60

CVE-2026-27798 is a medium-severity (CVSS 4) Out-of-bounds Read vulnerability in Magick.NET-Q16-AnyCPU. A fix is available for Magick.NET-Q16-AnyCPU — see the affected versions and patch details below.

ImageMagick: Heap Buffer Over-read in WaveletDenoise when processing small images

Also known asGHSA-qpgx-jfcq-r59f
Published
Updated
Affected
19 pkgs
Patched
19 / 19
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-27798.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs5th percentile — riskier than 5% of all scored CVEsHighest risk
0.00%0.23%0.47%0.70%0.0%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

19 pkgs affected
.NETMagick.NET-Q16-AnyCPU.NETMagick.NET-Q16-HDRI-AnyCPU.NETMagick.NET-Q16-HDRI-OpenMP-arm64.NETMagick.NET-Q16-HDRI-OpenMP-x64.NETMagick.NET-Q16-HDRI-arm64.NETMagick.NET-Q16-HDRI-x64.NETMagick.NET-Q16-HDRI-x86.NETMagick.NET-Q16-OpenMP-arm64+11 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.

Description

ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to versions 7.1.2-15 and 6.9.13-40, a heap buffer over-read vulnerability occurs when processing an image with small dimension using the -wavelet-denoise operator. Versions 7.1.2-15 and 6.9.13-40 contain a patch.

Affected Packages

19 total 19 fixed
EcosystemPackageVulnerable rangeFix
.NETNuGetMagick.NET-Q16-AnyCPUall versions14.10.3dotnet add package Magick.NET-Q16-AnyCPU --version 14.10.3
.NETNuGetMagick.NET-Q16-HDRI-AnyCPUall versions14.10.3dotnet add package Magick.NET-Q16-HDRI-AnyCPU --version 14.10.3
.NETNuGetMagick.NET-Q16-HDRI-OpenMP-arm64all versions14.10.3dotnet add package Magick.NET-Q16-HDRI-OpenMP-arm64 --version 14.10.3
.NETNuGetMagick.NET-Q16-HDRI-OpenMP-x64all versions14.10.3dotnet add package Magick.NET-Q16-HDRI-OpenMP-x64 --version 14.10.3
.NETNuGetMagick.NET-Q16-HDRI-arm64all versions14.10.3dotnet add package Magick.NET-Q16-HDRI-arm64 --version 14.10.3
.NETNuGetMagick.NET-Q16-HDRI-x64all versions14.10.3dotnet add package Magick.NET-Q16-HDRI-x64 --version 14.10.3

Affected Products

2 products · 3 configurations
Application
magick.netdlemstra
< 14.10.3
range
Application
imagemagickimagemagick
≥ 7.0.0-0 && < 7.1.2-15
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Magick.NET-Q16-AnyCPU, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update Magick.NET-Q16-AnyCPU to 14.10.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-27798 is resolved across your whole dependency graph.

  3. Workarounds

    Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

This MODERATE impact vulnerability in ImageMagick affects Red Hat Enterprise Linux. A heap buffer over-read can occur when processing images with small dimensions using the `-wavelet-denoise` operator. This flaw could lead to information disclosure or denial of service.

Workaround published by Red Hat
To reduce exposure, avoid processing untrusted or maliciously crafted images with ImageMagick. If processing untrusted content is necessary, consider executing ImageMagick operations within a sandboxed environment to contain potential risks.
Source: Red Hat security advisory for CVE-2026-27798 (CC BY 4.0)

Frequently Asked Questions

ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to versions 7.1.2-15 and 6.9.13-40, a heap buffer over-read vulnerability occurs when processing an image with small dimension using the `-wavelet-denoise` operator. Versions 7.1.2-15 and 6.9.13-40 contain a patch.
O3 Security · Impact-Aware SCA

Is CVE-2026-27798 in your dependencies?

Find it across NuGet, including transitive dependencies.

CVE-2026-27798: Magick.NET-Q16 — Fixed in 14.10.3