CVE-2026-26328 is a medium-severity (CVSS 6.5) CWE-284 vulnerability in openclaw. A fix is available for openclaw — see the affected versions and patch details below.
OpenClaw iMessage group allowlist authorization inherited DM pairing-store identities
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-26328.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
openclawnpmclawdbotnpmDescription
Summary
Under iMessage groupPolicy=allowlist, group authorization could be satisfied by sender identities coming from the DM pairing store, broadening DM trust into group contexts.
Details
Affected component: src/imessage/monitor/monitor-provider.ts.
Vulnerable logic derived effectiveGroupAllowFrom using both the static group allowlist and DM pairing-store identities (storeAllowFrom). This allowed a sender approved via DM pairing to satisfy group authorization in groups even if the sender/chat was not explicitly present in groupAllowFrom.
This weakens boundary separation between DM pairing and group allowlist authorization.
Affected Packages / Versions
openclaw(npm): affected<= 2026.2.13clawdbot(npm): affected<= 2026.1.24-3
Fix Commit(s)
openclaw/openclaw@872079d42fe105ece2900a1dd6ab321b92da2d59openclaw/openclaw@90d1e9cd71419168b2faa54a759b124a3eacfae7
Thanks @vincentkoc for reporting.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | openclaw | all versions | 2026.2.14npm install openclaw@2026.2.14 |
| 📦npm | clawdbot | all versions | 2026.2.14npm install clawdbot@2026.2.14 |
Affected Products
openclawopenclawDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openclaw, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update openclaw to 2026.2.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-26328 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2026-26328 in your dependencies?
Find it across npm, including transitive dependencies.