NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2026-25581 — sceditor

MEDIUMFix: samclarke/SCEditor@5733aed

CVE-2026-25581 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in sceditor. A fix is available for sceditor — see the affected versions and patch details below.

SCEditor affected by DOM XSS via emoticon URL/HTML injection

Also known asGHSA-25fq-6qgg-qpj8
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 22, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-25581.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk+0.03%
Lower risk than most CVEs21th percentile — riskier than 21% of all scored CVEsHighest risk
0.00%0.27%0.53%0.80%0.0%0.3%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

2other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
sceditornpm
852downloads / week

Description

If an attacker has the ability control configuration options passed to sceditor.create(), like emoticons, charset, etc. then it's possible for them to trigger an XSS attack due to lack of sanitisation of configuration options.

Proof of concept:

sceditor.create(textarea, {
  emoticons: {
    dropdown: { ':)': { url: 'x" onerror="window.__xss = true' } }
  }
});

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmsceditorall versions3.2.1npm install sceditor@3.2.1

Affected Products

1 product · 1 configurations
Application
sceditorsceditor
< 3.2.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for sceditor, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update sceditor to 3.2.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-25581 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

If an attacker has the ability control configuration options passed to `sceditor.create()`, like `emoticons`, `charset`, etc. then it's possible for them to trigger an XSS attack due to lack of sanitisation of configuration options. Proof of concept: ```js sceditor.create(textarea, { emoticons: { dropdown: { ':)': { url: 'x" onerror="window.__xss = true' } } } }); ```
O3 Security · Impact-Aware SCA

Is CVE-2026-25581 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2026-25581: sceditor XSS — Fixed in 3.2.1