CVE-2026-25153 — @backstage/plugin-techdoc…
HIGHCVE-2026-25153 is a high-severity (CVSS 7.7) Code Injection vulnerability in @backstage/plugin-techdocs-node. A fix is available for @backstage/plugin-techdocs-node — see the affected versions and patch details below.
@backstage/plugin-techdocs-node vulnerable to arbitrary code execution via MkDocs hooks
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-25153.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@backstage/plugin-techdocs-nodenpmDescription
Impact
When TechDocs is configured with runIn: local, a malicious actor who can submit or modify a repository's mkdocs.yml file can execute arbitrary Python code on the TechDocs build server via MkDocs hooks configuration.
Patches
Upgrade to @backstage/plugin-techdocs-node version 1.13.11, 1.14.1 or later.
The fix introduces an allowlist of supported MkDocs configuration keys. Unsupported configuration keys (including hooks) are now removed from mkdocs.yml before running the generator, with a warning logged to indicate which keys were removed.
Note: Users of @techdocs/cli should also upgrade to the latest version, which includes the fixed @backstage/plugin-techdocs-node dependency.
Workarounds
If you cannot upgrade immediately:
- Use Docker mode with restricted access: Configure TechDocs with
runIn: dockerinstead ofrunIn: local. This provides container isolation, though it does not fully mitigate the risk. - Restrict repository access: Limit who can modify
mkdocs.ymlfiles in repositories that TechDocs processes. Only allow trusted contributors. - Manual review: Implement PR review requirements for changes to
mkdocs.ymlfiles to detect malicioushooksconfigurations before they are merged. - Downgrade MkDocs: Use MkDocs < 1.4.0 (e.g., 1.3.1) which does not support hooks. Note: This may limit access to newer MkDocs features.
Note: Building documentation in CI/CD pipelines using @techdocs/cli does not mitigate this vulnerability, as the CLI uses the same vulnerable @backstage/plugin-techdocs-node package.
References
MkDocs Hooks Documentation MkDocs 1.4 Release Notes TechDocs Architecture
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @backstage/plugin-techdocs-node | ≥ 1.14.0&&< 1.14.1 | 1.14.1npm install @backstage/plugin-techdocs-node@1.14.1 |
| 📦npm | @backstage/plugin-techdocs-node | all versions | 1.13.11npm install @backstage/plugin-techdocs-node@1.13.11 |
Affected Products
backstagelinuxfoundationDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @backstage/plugin-techdocs-node, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @backstage/plugin-techdocs-node to 1.14.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-25153 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2026-25153 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Developer Hub 1.8 | rhdh/rhdh-hub-rhel9:1774545605 | RHSA-2026:6174 |
| Red Hat Developer Hub 1.9 | rhdh/rhdh-hub-rhel9:1775140647 | RHSA-2026:6802 |
Frequently Asked Questions
Is CVE-2026-25153 in your dependencies?
Find it across npm, including transitive dependencies.