CVE-2026-25152 is a medium-severity (CVSS 5.3) Path Traversal vulnerability in @backstage/plugin-techdocs-node. A fix is available for @backstage/plugin-techdocs-node — see the affected versions and patch details below.
@backstage/plugin-techdocs-node vulnerable to possible Path Traversal in TechDocs Local Generator
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-25152.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@backstage/plugin-techdocs-nodenpmDescription
Backstage is an open framework for building developer portals, and @backstage/plugin-techdocs-node provides common node.js functionalities for TechDocs. In versions of @backstage/plugin-techdocs-node prior to 1.13.11 and 1.14.1, a path traversal vulnerability in the TechDocs local generator allows attackers to read arbitrary files from the host filesystem when Backstage is configured with techdocs.generator.runIn: local. When processing documentation from untrusted sources, symlinks within the docs directory are followed by MkDocs during the build process. File contents are embedded into generated HTML and exposed to users who can view the documentation. This vulnerability is fixed in @backstage/plugin-techdocs-node versions 1.13.11 and 1.14.1. Some workarounds are available. Switch to runIn: docker in app-config.yaml and/or restrict write access to TechDocs source repositories to trusted users only.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @backstage/plugin-techdocs-node | ≥ 1.14.0&&< 1.14.1 | 1.14.1npm install @backstage/plugin-techdocs-node@1.14.1 |
| 📦npm | @backstage/plugin-techdocs-node | all versions | 1.13.11npm install @backstage/plugin-techdocs-node@1.13.11 |
Affected Products
backstagelinuxfoundationDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @backstage/plugin-techdocs-node, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @backstage/plugin-techdocs-node to 1.14.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-25152 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2026-25152 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2026-25152 in your dependencies?
Find it across npm, including transitive dependencies.