NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2026-24778 — ghost

HIGHFix: TryGhost/Ghost@da858e6

CVE-2026-24778 is a high-severity (CVSS 8.8) Cross-site Scripting (XSS) vulnerability in ghost. A fix is available for ghost — see the affected versions and patch details below.

Ghost vulnerable to XSS via malicious Portal preview links

Also known asBIT-ghost-2026-24778GHSA-gv6q-2m97-882h
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-24778.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs21th percentile — riskier than 21% of all scored CVEsHighest risk
0.00%0.26%0.53%0.79%0.0%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

8other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
ghostnpm
29Kdownloads / week
@tryghost/portalnpm
7Kdownloads / week

Description

Impact

An attacker was able to craft a malicious link that, when accessed by an authenticated staff user or member, would execute JavaScript with the victim's permissions, potentially leading to account takeover.

Vulnerable versions

This vulnerability is present in Ghost versions:

  • v5.43.0 to v5.120.4
  • v6.0.0 to v6.14.0

As well as in Portal versions:

  • v2.29.1 to v2.51.4
  • v2.52.0 to v2.57.0

Patches

Ghost automatically loads the latest patch of the members Portal component via CDN. Therefore:

  • For Ghost 5.x users, upgrading to v5.121.0 or later fixes the vulnerability (loads Portal v2.51.5, which contains the patch)
  • For Ghost 6.x users, upgrading to v6.15.0 or later fixes the vulnerability (loads Portal v2.57.1, which contains the patch)

For Ghost installations using a customised or self-hosted version of Portal, it will be necessary to manually rebuild from or update to the latest patch version.

References

Ghost thanks Younes Belalia for discovering and disclosing this vulnerability responsibly.

For more information

If users have any questions or comments about this advisory, email Ghost at [email protected].

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
📦npmghost≥ 5.43.0&&< 5.121.05.121.0npm install ghost@5.121.0
📦npm@tryghost/portal≥ 2.29.1&&< 2.51.52.51.5npm install @tryghost/portal@2.51.5
📦npm@tryghost/portal≥ 2.52.0&&< 2.57.12.57.1npm install @tryghost/portal@2.57.1
📦npmghost≥ 6.0.0&&< 6.15.06.15.0npm install ghost@6.15.0

Affected Products

2 products · 4 configurations
Application
ghostghost
≥ 6.0.0 && < 6.15.0
range
Application
portalghost
≥ 2.52.0 && < 2.57.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ghost, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ghost to 5.121.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-24778 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

### Impact An attacker was able to craft a malicious link that, when accessed by an authenticated staff user or member, would execute JavaScript with the victim's permissions, potentially leading to account takeover. ### Vulnerable versions This vulnerability is present in Ghost versions: - v5.43.0 to v5.120.4 - v6.0.0 to v6.14.0 As well as in Portal versions: - v2.29.1 to v2.51.4 - v2.52.0 to v2.57.0 ### Patches Ghost automatically loads the latest patch of the members Portal component via CDN. Therefore: - For Ghost 5.x users, upgrading to v5.121.0 or later fixes the vulnerability (loads
O3 Security · Impact-Aware SCA

Is CVE-2026-24778 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2026-24778: ghost — Fixed in 5.121.0