CVE-2026-23517 — fleet
Fix: fleetdm/fleet@5c030e3CVE-2026-23517 is a CWE-862 vulnerability in github.com/fleetdm/fleet. A fix is available for github.com/fleetdm/fleet — see the affected versions and patch details below.
Fleet has an Access Control vulnerability in debug/pprof endpoints
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-23517.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
github.com/fleetdm/fleet🐹github.com/fleetdm/fleet🐹github.com/fleetdm/fleet🐹github.com/fleetdm/fleet🐹github.com/fleetdm/fleet/v4Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Summary
A broken access control issue in Fleet allowed authenticated users to access debug and profiling endpoints regardless of role. As a result, low-privilege users could view internal server diagnostics and trigger resource-intensive profiling operations.
Impact
Fleet’s debug/pprof endpoints are accessible to any authenticated user regardless of role, including the lowest-privilege “Observer” role. This allows low-privilege users to access sensitive server internals, including runtime profiling data and in-memory application state, and to trigger CPU-intensive profiling operations that could lead to denial of service.
Patches
- 4.78.3
- 4.77.1
- 4.76.2
- 4.75.2
- 4.53.3
Workarounds
If an immediate upgrade is not possible, users should put the debug/pprof endpoints behind an IP allowlist.
For more information
If you have any questions or comments about this advisory:
Email us at [email protected] Join #fleet in osquery Slack
Credits
We thank @secfox-ai for responsibly reporting this issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/fleetdm/fleet | ≥ 4.78.0&&< 4.78.3 | 4.78.3go get github.com/fleetdm/fleet@v4.78.3 |
| 🐹Go | github.com/fleetdm/fleet | ≥ 4.77.0&&< 4.77.1 | 4.77.1go get github.com/fleetdm/fleet@v4.77.1 |
| 🐹Go | github.com/fleetdm/fleet | ≥ 4.76.0&&< 4.76.2 | 4.76.2go get github.com/fleetdm/fleet@v4.76.2 |
| 🐹Go | github.com/fleetdm/fleet | ≥ 4.75.0&&< 4.75.2 | 4.75.2go get github.com/fleetdm/fleet@v4.75.2 |
| 🐹Go | github.com/fleetdm/fleet/v4 | all versions | 4.78.3-0.20260112221730-5c030e32a3a9go get github.com/fleetdm/fleet/v4@v4.78.3-0.20260112221730-5c030e32a3a9 |
Affected Products
fleetfleetdmDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/fleetdm/fleet, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/fleetdm/fleet to 4.78.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-23517 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2026-23517 in your dependencies?
Find it across Go, including transitive dependencies.