NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2026-22733 — spring-boot-starter-actua…

HIGH

CVE-2026-22733 is a high-severity (CVSS 8.2) CWE-288 vulnerability in org.springframework.boot:spring-boot-starter-actuator. A fix is available for org.springframework.boot:spring-boot-starter-actuator — see the affected versions and patch details below.

Authentication Bypass under Actuator CloudFoundry endpoints

Also known asGHSA-mgvc-8q2h-5pgc
Published
Updated
Affected
5 pkgs
Patched
2 / 5
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-22733.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk+0.01%
Lower risk than most CVEs32th percentile — riskier than 32% of all scored CVEsHighest risk
0.00%0.29%0.58%0.88%0.0%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
☕org.springframework.boot:spring-boot-starter-actuator☕org.springframework.boot:spring-boot-starter-actuator☕org.springframework.boot:spring-boot-starter-actuator☕org.springframework.boot:spring-boot-starter-actuator☕org.springframework.boot:spring-boot-starter-actuator

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Spring Boot applications with Actuator can be vulnerable to an "Authentication Bypass" vulnerability when an application endpoint that requires authentication is declared under the path used by the CloudFoundry Actuator endpoints. This issue affects Spring Security: from 4.0.0 through 4.0.3, from 3.5.0 through 3.5.11, from 3.4.0 through 3.4.14, from 3.3.0 through 3.3.17, from 2.7.0 through 2.7.31.

Affected Packages

5 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.springframework.boot:spring-boot-starter-actuator≥ 4.0.0-M1&&< 4.0.44.0.4org.springframework.boot:spring-boot-starter-actuator:4.0.4
☕Mavenorg.springframework.boot:spring-boot-starter-actuator≥ 3.5.0&&< 3.5.123.5.12org.springframework.boot:spring-boot-starter-actuator:3.5.12
☕Mavenorg.springframework.boot:spring-boot-starter-actuator≥ 3.4.0No fix
☕Mavenorg.springframework.boot:spring-boot-starter-actuator≥ 3.0.0No fix
☕Mavenorg.springframework.boot:spring-boot-starter-actuatorall versionsNo fix

Affected Products

1 product · 5 configurations
Application
spring bootvmware
≥ 4.0.0 && < 4.0.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework.boot:spring-boot-starter-actuator, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.springframework.boot:spring-boot-starter-actuator to 4.0.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-22733 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Spring Boot applications with Actuator can be vulnerable to an "Authentication Bypass" vulnerability when an application endpoint that requires authentication is declared under the path used by the CloudFoundry Actuator endpoints. This issue affects Spring Security: from 4.0.0 through 4.0.3, from 3.5.0 through 3.5.11, from 3.4.0 through 3.4.14, from 3.3.0 through 3.3.17, from 2.7.0 through 2.7.31.
O3 Security · Impact-Aware SCA

Is CVE-2026-22733 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2026-22733: spring-boot-starter — Fixed in 4.0.4