NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2026-21450 — bagisto

Fix: bagisto/bagisto@3f294b4

CVE-2026-21450 is a CWE-1336 vulnerability in bagisto/bagisto. A fix is available for bagisto/bagisto — see the affected versions and patch details below.

Bagisto has SSTI in parameter that can lead to RCE

Also known asGHSA-9hvg-qw5q-wqwp
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-21450.

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk-0.01%
Lower risk than most CVEs72th percentile — riskier than 72% of all scored CVEsHighest risk
0.12%0.71%1.30%1.89%0.7%1.4%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐘bagisto/bagisto

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Summary

SSTI is possible in Bagisto via type parameter can lead to RCE and other exploitations.

Details

  1. Go to http://127.0.0.1:8000/admin/reporting/products/view?type={{7*7}}
<img width="1251" height="282" alt="image" src="https://github.com/user-attachments/assets/652e96f4-631e-4322-8561-63f4d897a480" />

Impact

Can lead to RCE, command injection.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistbagisto/bagistoall versions2.3.10composer require bagisto/bagisto:^2.3.10

Affected Products

1 product · 1 configurations
Application
bagistowebkul
< 2.3.10
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for bagisto/bagisto, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update bagisto/bagisto to 2.3.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-21450 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

### Summary SSTI is possible in Bagisto via type parameter can lead to RCE and other exploitations. ### Details 1. Go to `http://127.0.0.1:8000/admin/reporting/products/view?type={{7*7}}` <img width="1251" height="282" alt="image" src="https://github.com/user-attachments/assets/652e96f4-631e-4322-8561-63f4d897a480" /> ### Impact Can lead to RCE, command injection.
O3 Security · Impact-Aware SCA

Is CVE-2026-21450 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2026-21450: bagisto RCE — Fixed in 2.3.10