CVE-2026-1703 — pip
Fix: pypa/pip@8e227a9CVE-2026-1703 is a Path Traversal vulnerability in pip. A fix is available for pip — see the affected versions and patch details below.
Limited path traversal when installing wheel archives
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-1703.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
pipReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
When pip is installing and extracting a maliciously crafted wheel archive, files may be extracted outside the installation directory. The path traversal is limited to prefixes of the installation directory, thus isn't able to inject or overwrite executable files in typical situations.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | pip | all versions | 26.0pip install --upgrade 'pip==26.0' |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pip, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update pip to 26.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-1703 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This LOW impact flaw in pip allows information disclosure via path traversal when installing crafted wheel archives. While files may be extracted outside the installation directory, the traversal is limited to prefixes of the installation directory, preventing injection or overwriting of executable files in typical…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.Source: Red Hat security advisory for CVE-2026-1703 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Hardened Images | python-pip-main-26.0.1-2.1.hum1 | RHSA-2026:7610 |
| Red Hat OpenShift AI 3.0 | rhai/base-image-rocm-rhel9:1793041981 | RHSA-2026:91219 |
| Red Hat OpenShift AI 3.0 | rhai/base-image-cpu-rhel9:1793042072 | RHSA-2026:91232 |
| Red Hat OpenShift AI 3.0 | rhai/base-image-cuda-rhel9:1793042067 | RHSA-2026:91236 |
| Red Hat OpenShift AI 3.0 | rhai/base-image-cpu-rhel9:1793329709 | RHSA-2026:94459 |
| Red Hat OpenShift AI 3.0 | rhai/base-image-cuda-rhel9:1793328358 | RHSA-2026:94476 |
Frequently Asked Questions
Is CVE-2026-1703 in your dependencies?
Find it across PyPI, including transitive dependencies.