CVE-2013-5123 — pip
MEDIUMCVE-2013-5123 is a medium-severity (CVSS 5.9) Improper Authentication vulnerability in pip. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for pip — see the affected versions and patch details below.
Improper Authentication in pip
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
pipReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
The mirroring support (-M, --use-mirrors) in Python Pip before 1.5 uses insecure DNS querying and authenticity checks which allows attackers to perform man-in-the-middle attacks.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | pip | all versions | 1.5pip install --upgrade 'pip==1.5' |
Affected Products
debian linuxdebianfedorafedoraprojectpippypaopenshiftredhatsoftware collectionsredhatvirtualenvvirtualenvResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
phlyLabs phlyMail Lite 4.03.04 - 'go' Open Redirect
by LiquidWorm · Jan 13, 2013
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pip, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update pip to 1.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-5123 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2013-5123 in your dependencies?
Find it across PyPI, including transitive dependencies.