NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 Bitnami
Not in CISA KEV

CVE-2026-1337 — neo4j

CVE-2026-1337 is a CWE-117 vulnerability in neo4j. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for neo4j — see the affected versions and patch details below.

Insufficient escaping of unicode characters in query log

Also known asBIT-neo4j-enterprise-2026-1337GHSA-xr72-g735-4vwp
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-1337.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk-0.00%
Lower risk than most CVEs16th percentile — riskier than 16% of all scored CVEsHighest risk
0.00%0.25%0.50%0.75%0.0%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
📦neo4j

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Bitnami packages — download data is not available via public APIs for these ecosystems.

Description

Insufficient escaping of unicode characters in query log in Neo4j Enterprise and Community editions prior to 2026.01 can lead to XSS if the user opens the logs in a tool that treats them as HTML. There is no security impact on Neo4j products, but this advisory is released as a precaution to treat the logs as plain text if using versions prior to 2026.01.

Proof of concept exploit:  https://github.com/JoakimBulow/CVE-2026-1337

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦Bitnamineo4jall versions2026.1.0

Affected Products

1 product · 2 configurations
Application
neo4jneo4j
< 2026.01.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for neo4j, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update neo4j to 2026.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-1337 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Insufficient escaping of unicode characters in query log in Neo4j Enterprise and Community editions prior to 2026.01 can lead to XSS if the user opens the logs in a tool that treats them as HTML. There is no security impact on Neo4j products, but this advisory is released as a precaution to treat the logs as plain text if using versions prior to 2026.01. Proof of concept exploit:  https://github.com/JoakimBulow/CVE-2026-1337
O3 Security · Impact-Aware SCA

Is CVE-2026-1337 in your dependencies?

Find it across Bitnami, including transitive dependencies.

CVE-2026-1337: neo4j XSS — Fixed in 2026.1.0