CVE-2026-0994 — protobuf
Fix: protocolbuffers/protobuf#25239CVE-2026-0994 is a CWE-674 vulnerability in protobuf. A fix is available for protobuf — see the affected versions and patch details below.
Denial of Service in Python Protobuf
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-0994.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
protobuf🐍protobufReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
A denial-of-service (DoS) vulnerability exists in google.protobuf.json_format.ParseDict() in Python, where the max_recursion_depth limit can be bypassed when parsing nested google.protobuf.Any messages.
Due to missing recursion depth accounting inside the internal Any-handling logic, an attacker can supply deeply nested Any structures that bypass the intended recursion limit, eventually exhausting Python’s recursion stack and causing a RecursionError.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | protobuf | ≥ 6.30.0rc1&&< 6.33.5 | 6.33.5pip install --upgrade 'protobuf==6.33.5' |
| 🐍PyPI | protobuf | all versions | 5.29.6pip install --upgrade 'protobuf==5.29.6' |
Affected Products
protobufgoogleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for protobuf, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update protobuf to 6.33.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-0994 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This vulnerability is rated Important for Red Hat products. The flaw in `protobuf` allows a remote attacker to trigger a denial-of-service by providing specially crafted, deeply nested `google.protobuf.Any` messages to the `google.protobuf.json_format.ParseDict()` function. This bypasses the intended recursion depth…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.Source: Red Hat security advisory for CVE-2026-0994 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Ansible Automation Platform 2.5 for RHEL 8 | python3.12-protobuf-0:5.29.6-1.el8ap | RHSA-2026:3959 |
| Red Hat Ansible Automation Platform 2.6 for RHEL 9 | python3.12-protobuf-0:5.29.6-1.el9ap | RHSA-2026:3958 |
| Red Hat Enterprise Linux 10 | protobuf-0:3.19.6-15.el10_1 | RHSA-2026:3094 |
| Red Hat Enterprise Linux 10.0 Extended Update Support | protobuf-0:3.19.6-11.el10_0.1 | RHSA-2026:3218 |
| Red Hat Enterprise Linux 9 | protobuf-0:3.14.0-17.el9_7 | RHSA-2026:3095 |
| Red Hat Enterprise Linux 9.0 Update Services for SAP Solutions | protobuf-0:3.14.0-9.el9_0.1 | RHSA-2026:3097 |
| Red Hat Enterprise Linux 9.2 Update Services for SAP Solutions | protobuf-0:3.14.0-13.el9_2.1 | RHSA-2026:3220 |
| Red Hat Enterprise Linux 9.4 Extended Update Support | protobuf-0:3.14.0-13.el9_4.1 | RHSA-2026:3059 |
Frequently Asked Questions
Is CVE-2026-0994 in your dependencies?
Find it across PyPI, including transitive dependencies.