CVE-2025-4565 — protobuf
Fix: protocolbuffers/protobuf@17838beCVE-2025-4565 is a CWE-674 vulnerability in protobuf. A fix is available for protobuf — see the affected versions and patch details below.
Unbounded recursion in Python Protobuf
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-4565.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
protobuf🐍protobuf🐍protobufReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Summary
Any project that uses Protobuf pure-Python backend to parse untrusted Protocol Buffers data containing an arbitrary number of recursive groups, recursive messages or a series of SGROUP tags can be corrupted by exceeding the Python recursion limit.
Reporter: Alexis Challande, Trail of Bits Ecosystem Security Team [email protected]
Affected versions: This issue only affects the pure-Python implementation of protobuf-python backend. This is the implementation when PROTOCOL_BUFFERS_PYTHON_IMPLEMENTATION=python environment variable is set or the default when protobuf is used from Bazel or pure-Python PyPi wheels. CPython PyPi wheels do not use pure-Python by default.
This is a Python variant of a previous issue affecting protobuf-java.
Severity
This is a potential Denial of Service. Parsing nested protobuf data creates unbounded recursions that can be abused by an attacker.
Proof of Concept
For reproduction details, please refer to the unit tests decoder_test.py and message_test
Remediation and Mitigation
A mitigation is available now. Please update to the latest available versions of the following packages:
- protobuf-python(4.25.8, 5.29.5, 6.31.1)
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | protobuf | all versions | 4.25.8pip install --upgrade 'protobuf==4.25.8' |
| 🐍PyPI | protobuf | ≥ 5.26.0rc1&&< 5.29.5 | 5.29.5pip install --upgrade 'protobuf==5.29.5' |
| 🐍PyPI | protobuf | ≥ 6.30.0rc1&&< 6.31.1 | 6.31.1pip install --upgrade 'protobuf==6.31.1' |
Affected Products
protobuf-pythongoogleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for protobuf, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update protobuf to 4.25.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-4565 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
The availability impact of this denial-of-service vulnerability is confined to applications that directly integrate the Protobuf package. Within the context of a Red Hat system, the host machine itself is not expected to be impacted, thereby limiting the scope of disruption to individual application instances rather…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2025-4565 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Ansible Automation Platform 2.6 for RHEL 9 | python3.11-protobuf-0:4.25.8-1.el9ap | RHSA-2026:1249 |
| Red Hat OpenShift Container Platform 4.19 | openshift4/ose-dpu-intel-ipu-vsp-rhel9:v4.19.0-202507081507.p0.gb4d5e23.assembly.stream.el9 | RHSA-2025:10773 |
| Red Hat Ansible Automation Platform 2.6 | ansible-automation-platform-26/gateway-rhel9:1772543959 | RHSA-2026:3960 |
Frequently Asked Questions
Is CVE-2025-4565 in your dependencies?
Find it across PyPI, including transitive dependencies.