CVE-2026-0636 — bcprov-jdk14
Fix: bcgit/bc-java@d20cdb8CVE-2026-0636 is a CWE-90 vulnerability in org.bouncycastle:bcprov-jdk14. A fix is available for org.bouncycastle:bcprov-jdk14 — see the affected versions and patch details below.
LDAP Injection Vulnerability in LDAPStoreHelper.java
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-0636.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.bouncycastle:bcprov-jdk14☕org.bouncycastle:bcprov-jdk15to18☕org.bouncycastle:bcprov-jdk18on☕org.bouncycastle:bcprov-jdk14☕org.bouncycastle:bcprov-jdk15to18☕org.bouncycastle:bcprov-jdk18on☕org.bouncycastle:bcprov-jdk14☕org.bouncycastle:bcprov-jdk15to18+1 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Improper neutralization of special elements used in an LDAP query ('LDAP injection') vulnerability in Legion of the Bouncy Castle Inc. BC-JAVA bcprov on all (prov modules). This vulnerability is associated with program files LDAPStoreHelper.
Issue affecting: BC 1.74 to 1.80.1, BC 1.81, BC 1.82 to BC 1.83.
Fixed versions: BC 1.80.2, BC 1.81.1, BC 1.84
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.bouncycastle:bcprov-jdk14 | ≥ 1.74&&< 1.80.2 | 1.80.2org.bouncycastle:bcprov-jdk14:1.80.2 |
| ☕Maven | org.bouncycastle:bcprov-jdk15to18 | ≥ 1.74&&< 1.80.2 | 1.80.2org.bouncycastle:bcprov-jdk15to18:1.80.2 |
| ☕Maven | org.bouncycastle:bcprov-jdk18on | ≥ 1.74&&< 1.80.2 | 1.80.2org.bouncycastle:bcprov-jdk18on:1.80.2 |
| ☕Maven | org.bouncycastle:bcprov-jdk14 | ≥ 1.81&&< 1.81.1 | 1.81.1org.bouncycastle:bcprov-jdk14:1.81.1 |
| ☕Maven | org.bouncycastle:bcprov-jdk15to18 | ≥ 1.81&&< 1.81.1 | 1.81.1org.bouncycastle:bcprov-jdk15to18:1.81.1 |
| ☕Maven | org.bouncycastle:bcprov-jdk18on | ≥ 1.81&&< 1.81.1 | 1.81.1org.bouncycastle:bcprov-jdk18on:1.81.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.bouncycastle:bcprov-jdk14, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.bouncycastle:bcprov-jdk14 to 1.80.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-0636 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
To exploit this issue, an attacker needs to submit crafted input to an application using the `LDAPStoreHelper` implementation for directory queries. An attack typically requires the application to pass the malicious input directly into a search filter, allowing the attacker to modify the resulting LDAP query. The…
To mitigate this flaw, sanitize all user-supplied input to remove or escape LDAP special characters before passing it to the LDAPStoreHelper for directory queries. If the input contains unexpected metacharacters such as asterisks, parentheses or backslashes, reject the request or escape the characters.Source: Red Hat security advisory for CVE-2026-0636 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat AMQ Broker 7.12.7 | bcprov-jdk18on | RHSA-2026:14276 |
| Red Hat AMQ Broker 7.13.5 | bcprov-jdk18on | RHSA-2026:14272 |
| Red Hat AMQ Broker 7.14.1 | bcprov-jdk18on | RHSA-2026:66488 |
| Red Hat Build of Apache Camel 4.14 for Quarkus 3.27 | bcprov-jdk18on | RHSA-2026:13631 |
| Red Hat build of Apache Camel 4.18.1 for Spring Boot 3.5.14 | bcprov-debug-jdk15on | RHSA-2026:17668 |
| Red Hat build of Quarkus 3.20.6.SP1 | org.bouncycastle/bcprov-jdk18on:1.84.0.redhat-00001 | RHSA-2026:11720 |
| Red Hat build of Quarkus 3.27.3.SP1 | org.bouncycastle/bcprov-jdk18on:1.84.0.redhat-00001 | RHSA-2026:11721 |
| Red Hat JBoss Enterprise Application Platform 7.4.25 | bcprov-jdk12 | RHSA-2026:53806 |
Frequently Asked Questions
Is CVE-2026-0636 in your dependencies?
Find it across Maven, including transitive dependencies.