CVE-2025-8916 — bcpkix-jdk15on
Fix: bcgit/bc-java@310b30aCVE-2025-8916 is a CWE-770 vulnerability in org.bouncycastle:bcpkix-jdk15on. A fix is available for org.bouncycastle:bcpkix-jdk15on — see the affected versions and patch details below.
Possible DOS in processing large name constraint structures in PKIXCertPathReveiwer
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-8916.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.bouncycastle:bcpkix-jdk15on☕org.bouncycastle:bcpkix-jdk15to18☕org.bouncycastle:bcpkix-jdk18on☕org.bouncycastle:bcpkix-fips☕org.bouncycastle:bcpkix-fipsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Allocation of Resources Without Limits or Throttling vulnerability in Legion of the Bouncy Castle Inc. BC Java bcpkix on All (API modules), Legion of the Bouncy Castle Inc. BC Java bcprov on All (API modules), Legion of the Bouncy Castle Inc. BCPKIX FIPS bcpkix-fips on All (API modules) allows Excessive Allocation. This vulnerability is associated with program files https://github.Com/bcgit/bc-java/blob/main/pkix/src/main/java/org/bouncycastle/pkix/jcajce/PKIXCertPathReviewer.Java, https://github.Com/bcgit/bc-java/blob/main/prov/src/main/java/org/bouncycastle/x509/PKIXCertPathReviewer.Java.
This issue affects BC Java: from 1.44 through 1.78; BC Java: from 1.44 through 1.78; BCPKIX FIPS: from 1.0.0 through 1.0.7, from 2.0.0 through 2.0.7.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.bouncycastle:bcpkix-jdk15on | ≥ 1.44&&< 1.79 | 1.79org.bouncycastle:bcpkix-jdk15on:1.79 |
| ☕Maven | org.bouncycastle:bcpkix-jdk15to18 | ≥ 1.44&&< 1.79 | 1.79org.bouncycastle:bcpkix-jdk15to18:1.79 |
| ☕Maven | org.bouncycastle:bcpkix-jdk18on | ≥ 1.44&&< 1.79 | 1.79org.bouncycastle:bcpkix-jdk18on:1.79 |
| ☕Maven | org.bouncycastle:bcpkix-fips | ≥ 1.0.0&&< 1.0.8 | 1.0.8org.bouncycastle:bcpkix-fips:1.0.8 |
| ☕Maven | org.bouncycastle:bcpkix-fips | ≥ 2.0.0&&< 2.0.8 | 2.0.8org.bouncycastle:bcpkix-fips:2.0.8 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.bouncycastle:bcpkix-jdk15on, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.bouncycastle:bcpkix-jdk15on to 1.79 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-8916 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2025-8916 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2025-8916 in your dependencies?
Find it across Maven, including transitive dependencies.